Strange size error during restore task



  • I created an image with the following specs:

    https://photos.app.goo.gl/GSeppMzFgPF7fAx1A

    Captured, all good. I started a test restore and I get this:

    https://photos.app.goo.gl/XC4Fffhr9ZtCpK2T9

    104 is not smaller than 104 :D



  • Done testing and I can confirm that AOMEI Backupper causes the problem.

    I re-captured the image using dism, injected the install.wim into the install media, installed from it (essentially allowing Windows installer to re-create the EFI and MS reserved partitions) and now the restore works perfectly.

    This error still appears:
    https://photos.app.goo.gl/7UWrM7y2dNgELa8E9

    But it has no negative impact on capture or restore.

    So, the bottom line is that, from now on, I won’t capture any drives that were restored with AOMEI.

    AOMEI is a very good free tool, I’ll still use it but only for images that go to the final user, not images that are captured for deployment.



  • @Sebastian-Roth
    Unfortunately I saw you message too late. I re-imaged my FOG server so I cannot copy the files (I have a dual boot laptop as deployment machine and had some issues with Windows, so I had to re-image).
    But I’ll test again and send you the files.

    The OS is Windows but I am going to set up a dual boot in the next few days, that is why I chose Linux in the image settings (I wanted to use the same image).

    But I think I know who is to blame for the problem: AOMEI Backupper. I had a backup made with it and restored it, checking the feature that aligns the partitions on SSDs. And I believe that messed up the size of the partition.

    I’m going to work on this issue on Monday and let you know how it goes.


  • Developer

    @andreiv What OS do you have installed on that machine you capture from? In the image OS is set to Linux but in the other outputs I see two NTFS filesystems and non EXTFS. If this is a dual boot installation with Linux filesystem other than EXT2/3/4 then this might be fine. Just trying to not overlook anything obvious here.

    Can you please post the contents of the (text) files /images/DefLabImg/d1.partitions, /images/DefLabImg/d1.minimum.partitions and /images/DefLabImg/d1.fixed_size_partitions?



  • I did capture the same drive with AOMEI Backupper and restored it without any problems.



  • Captured and tried to restore again. Same error.
    But I noticed an error during capture:

    https://photos.app.goo.gl/okdKKieQ4HgYaUHo9



  • No, I didn’t change the image settings at all. Just captured and restored.


  • Developer

    @andreiv Did you change the image type from non-resizable to resizable in between?

    The error message is misleading. Partclone checks the partition sizes exactly (to the sector) and fails if they don’t match exactly.


Log in to reply
 

555
Online

5.6k
Users

12.8k
Topics

121.1k
Posts