SOLVED db_root: cannot open: /etc/target


  • After getting a device to start capturing an image I am prompted by this error:
    db_root: cannot open: /etc/target
    I am new to Ubuntu and I need some help here. Thanks

    My setup is:
    Dell R710
    Ubuntu 16.04 server
    2 drives in RAID 0


  • I have since messed with my setup and no longer have the error. Sorry but I did not get a screenshot of the warning.

  • Senior Developer

    @cary1102 Sorry for spoiling your post! Hope you don’t mind the quick discussion on the db_root warning issue. Will be fixed soon although it’s not causing any problems.

    Please help us with some more information on what you see after the db_root warning.

  • Moderator

    @Sebastian-Roth I can’t think of any reason why or even how we could pass iscsi target information to FOS. FOS uses NFS file share. I can’t think of an imaging reason why we would want to use a block level device that can’t be shared with other FOS imaging targets at the same time. (I know its a bit rambley way of saying take it out its not needed and only causes confusion with the imaging techs)


  • @Sebastian-Roth I think it’s worth it. I can’t imagine a scenario where you’d be putting an image on an iscsi target.

  • Senior Developer

    As this has been asked a couple of times now and we also have an issue open in github I though I might look into this.

    It’s kind of strange that I still get the error even if I add that directory to the init file. I have had a look a the kernel code and can’t see why this fails. Possibly it’s because our root is not on a disk but in RAM? I am not sure. Shouldn’t make a difference really.

    Then I had a closer look at which part of the kernel that is. It’s within the SCSI target driver. See more information about it here: https://lwn.net/Articles/424004/ and https://en.wikipedia.org/wiki/LIO_(SCSI_target)

    I can’t imagine anyone would need this within the FOS system at all. @Tom-Elliott @george1421 What do you guys think. We might just remove CONFIG_TARGET_CORE from our kernel config and that’s it.


  • You’re not giving us the full information.

    The message as you see it is not what’s causing your problem.

    A picture of the error in context will be much more useful than a single line that you’re seeing on a screen.

270
Online

8.7k
Users

15.4k
Topics

144.1k
Posts