Dell 5591: TFTP works for Legacy but not UEFI



  • We just received a large batch of Dell E5591 laptops. We are wanting to use UEFI to install and image these laptops. We can PXE boot these to our Fog server (hosted on Ubuntu 16.04) using Legacy boot. Unfortunately, this does not work when we try to PXE boot using UEFI.

    the laptop gets an IP from the DHCP the fog IP and the ipxe.efi file name from the Fog server, but never appears to try the TFTP connection.

    I have used tcpdump on the Fog server and can watch the full transaction for the DHCP (ports 67 and 68) and TFTP (port 69) and everything works great when booting via Legacy. For the UEFI boot, I can see the laptop receives the DHCP IP, the Fog server IP and the file to download (ipxe.efi), but the laptop never appears to try the TFTP connection.

    Also, briefly displayed during the PXE UEFI boot, the following is displayed:

    Server IP address is 192.168.10.10.
    NBP filename is pxe.efi
    NBP file size is 0 bytes.
    PXE-E99: Unexpected network error.
    

    I know this is likely a laptop issue and not Fog, but curious if anyone else has experienced a similar issue. We have verified the laptop is up to date with Dell firmware.


  • Developer

    @EricLA2K Thanks heaps for keeping us posted. I am fairly sure this will help other users as well!!



  • This was indeed a BIOS issue. Dell released 1.6.1 for the 5591 on Feb. 25. We have updated to 1.6.1 and the UEFI boot now works.


  • Moderator

    @george1421 I did hop onto chat to discuss things with the OP a bit quicker. We’ve come down to the possibility that its the 5591’s in uefi mode that has the problem. The OP is going to confirm next week if an different dell laptop in uefi mode pxe boots correctly. I’m thinking that there is something up with the 5591 firmware. Looking at the pcap the target rom is getting what it needs for dhcp, its just never contacting the tftp server for the ipxe boot kernel.


  • Moderator

    @EricLA2K ok very good. I didn’t see the tftp request. So knowing it was from the fog server will change my search a bit.



  • @george1421 Tcpdump was taken from the FOG server. Here was the command used:

    $ tcpdump -i ens192 -e -n -s 0 port 67 or port 68 or port 69 or port 4011
    

  • Moderator

    @EricLA2K Was that pcap taken using the FOG server or did you use wireshark on a second computer?



  • Typo indeed. That should be “ipxe.efi.”

    Here is a link for both a capture with Legacy followed by UEFI and UEFI only: https://drive.google.com/open?id=1_q2vTgCfB5P433nz0lQphR2v5W92d_AW


  • Moderator

    hopefully its just a type-o but the uefi boot loader is ipxe.efi.

    If you saved the pcap of the uefi boot, I’d be willing to look at it. Upload it to a google drive and share it publicly. Then post the link here. That way you can take down the pcap without anything left behind.


Log in to reply
 

480
Online

5.9k
Users

13.2k
Topics

124.1k
Posts