SOLVED DHCP Lease Failing on 1.5.5 after upgrade

  • Hi again.

    Today I need to install some HP Prodesk 400 G4 (With a HP Prodesk 400 G3 after a bios upgrade it’s working ans with a Dell Optiplex 3060 it’s working too)

    And I have the following problem:

    DHCP Lease Failing

    The problem is on both boot mod mod (uefi and legacy) I try to check for a Bios update, and I done it but the problem steal here.

    I already try with a old no managed dumb switch.

    In my case I make a upgrade from 1.4.4 to 1.5.5 it was working like a charm with the 1.4.4. Now I have this problem with the 1.5.5.

    Any idea ?

  • Had the same issue, reverting to 4.18 kernel solved it.


    on debug mode the
    ip addr show had network interface visible but without proper address
    udhcpc failed to get addy
    sorry no lspci was in a hurry

  • Senior Developer

    @totoro Sounds like you have a rough DHCP server somewhere in your network! Read about this topic on the web and try to find it.

    Yes it’s true, but the message is the same,

    I am fairly sure the IP address is also different!!! Next time post your own picture!

  • @Sebastian-Roth Yes it’s true, but the message is the same, so the only difference is the version of udhcpc who is v1.29.2 but I’m agree with your point of view.

    @george1421 I don’t know why, but I can’t run FOS all the time I get the reboot message in 1 minute. Did they have other key to press in same time ? Did y have do hold enter key ?

    So I don’t understand why, but today it start to work (it make me crazy to don’t understand)… so I will say it’s a mysterious network problem.

    Thank’s for helping.

  • Moderator

  • Senior Developer

    @totoro Do I get this right? Did you re-use the picture from this post here ??

    Please take a picture of the actual error on the screen of your client and post here. We can’t help you if you don’t give us the exact details. Most instructions on debugging and assumptions on the actual error are based on the information you give. If it’s just “looks like this” we might be way off!

  • Moderator

    I guess the first thing I would do is schedule a debug capture/deploy (doesn’t matter). Then pxe boot the target computer. After a few enter key presses you should be dropped to a linux (FOS) command prompt on the target computer.

    From the FOS command prompt I would key in…

    1. ip addr show and post the output here. My hope is that eth0 is present, shows a mac address and an IP address. Watch to see if there are more ethernet adapters detected other than eth0
    2. If step 1 fails, then issue /sbin/udhcpc -i eth0 --now My hope is that it will pick up a dhcp address. If it gets an IP address then try to ping ping
    3. If step 2 fails, then issue lspci -nn|grep etwork and post the results here.