UNSOLVED FOG server not picking up custom background

  • Hi there,

    For my non-profit I have set-up a fog server and it works great except for a couple of things.

    Whenever I set a custom background for the pxe menu, the colors revert back to black/red and no image. (See picture).
    When I use the settings -> ipxe menu settings -> name of file.png it displays the red/black screen. But bg.png works.

    I’ve copied the image to the same folder as the bg.png (/downloads/fogproject-1.5.5/packages/web/service/ipxe)


    Also, sometimes when I image a image with our general win 10 uefi image, it does not apply the windows boot manager. If you add it manually in the bios, then it loads fine. This is not on all systems, but mostly dell ones.


  • Moderator

    Here are a couple of ideas.
    Make sure the geometry of file.png matches (exactly) the geometry and color depth of bg.png. Also if I remember correctly size does matter. There is a maximum total byte count of this background image.

    Secondly some uefi firmware can’t / doesn’t display background images. There is nothing you can do it make it work, its flaky uefi firmware.

    As for the uefi boot manager. Yes I’ve seen that myself. I think one of the developers was going to look into that issue. I don’t know if the fix will be in 1.5.6 or 1.5.7 if they can work it out. One of the issues we’ve seen is some people want windows to be the first boot option after imaging and other want to keep what ever boot order they currently have and not have FOG change the boot order.