"Windows could not complete the installation" after image deployed.

  • The full message is “Windows could not complete the installation. To install windows on this computer, restart the installation”.

    Fresh install of Windows 10 1809
    Newly built and validated answer file from Windows System Image Manager.
    Original computer reboots after image upload and completes sysprep process as it should.
    Cloned machine gets error.

    Has anyone experienced this message before?
    I have tried new install media, new sysprep file. Tried just installing windows without anything other than base install and updates. Any assistance would be appreciated.


  • @george1421 yes it was. I also had to create the Scripts folder, it was not there by default. After adding that folder and the setupcomplete.cmd, I ran sysprep again with the unattend.xml file after adding the firstlogoncommand section to the file, deployed to my other test machine and everything worked according to plan.

  • Moderator

    @dooleyrd Was the FOG Client service enabled in your golden image?

    For others that might find this thread: https://wiki.fogproject.org/wiki/index.php/FOG_Client#FOG_Client_with_Sysprep

  • @george1421 The setupcomplete.cmd worked like a champ. Thank you very much for your advice.

  • Moderator

    I have seen this many times for different reasons. I would say the most common with FOG is that when you built the golden image, you did not disable the FOG Service according to the wiki page. Then the fog service should be started in the setupcomplete.cmd batch file.

    You will get this error above under several conditions, the most common is the target computer rebooting unexpectedly during WinSetup/OOBE stage. If the FOG client is left running when the image is captured. When deployed the FOG Client will start working before OOBE has finished. Part of the FOG Client’s job is to rename the target computer and reboot. If this happens during OOBE you will get the above error because of the unexpected (to OOBE) reboot.

    Other places I’ve seen this is if a bad driver is installed causing the target computer to reboot before OOBE is finished.

    If either of these are not your case there is additional debugging you can do, but lets not go into that unless its needed.

Log in to reply