Linux Mint 19 V2 Emergency mode with toram Parameters

  • Sorry if this is the wrong category.

    I’m a little stumped trying to get Linux Mint 19 v2 to PXE Boot.

    I read through the tutorial “Using FOG to PXE boot into your favorite installer images” and as far as I know have everything set correctly but I am still booting emergency mode. It’s probably something simple but I am quite new to all of this.

    Here are my set parameters and I’m running Debian 9.5 if that helps.

    kernel tftp://${fog-ip}/mint/19/vmlinuz
    initrd tftp://${fog-ip}/mint/19/initrd.lz
    imgargs vmlinuz root=/dev/nfs boot=casper netboot=nfs nfsroot=${fog-ip}:/images/os/mint/19/ locale=en_US.UTF-8 keyboard-configuration/layoutcode=us toram quiet splash
    boot || goto MENU

    Thanks for any help provided!


  • @george1421 Okay so 19.1 seems to work great, on my desktop. The only thing I had to do different was change the permissions on the 19.1 folder since it locked it down to root but that was most likely from me running the terminal in “su” I’m guessing.

    For some odd reason the laptop I’ve been using to test these does not want to boot it still and I am not sure why, it boots the Windows and Debian installers fine which is odd. It is plugged in with an ethernet cable the same as the desktop. I’m guessing this may have been giving me some of the issues in the past but I did double check on my desktop before posting and it was not going in my case.

    I must be missing something in Mint 19 v2 but I’m not going to worry about it at this point since 19.1 is working great. I am doing the install right now and it so far is having no issues.

    Thank you for all your help and if I figure out what the issue is with the laptop I’ll be sure to share in case anyone else happen to come across a similar issue.


  • Moderator


    I just ran through this without issue. I did use @Gamienator toram kernel parameter. I pxe booted a Dell o7010 into the linux mint installer. I did not attempt to install from there, but the installer is indeed running LM 19.1.

  • @george1421

    Ok so I did mix and match the two while trying to get things going but I’m definitely using the NFS Protocol as I was following your guide.

    I went through and did a setup of Mint 18.1 step by step from your guide and it works perfect.

    I did not realize Mint had a new release so I’ll get that downloading and test it using the same tutorial once again.

  • Moderator

    @Gurf OK lets make sure we are not mixing protocols here. In my tutorial I’m using the NFS protocol. The NFS shared path currently used on the FOG server is /images. So I placed the LM files under /images. Now its possible to use the http protocol to boot also. It appears that is what @Gamienator has done since he is using the http server base path of var/www/html. So there are two uri’s that could be in play here. If you are using the http:// protocol then the base path is var/www/html if you are using the nfs:// protocol the default base path is /images.

    Because I have other reasons to do this, I’m downloading LM 19.1 cinnamon to see how bad I can mess up that netbooting. I’ll let you know when I have it downloaded and tested.

  • @Gamienator

    Thanks for your reply.

    The “quite slash” line is from the Linux Mint 18.1 guide that was made by George. I used the same parameters lines changing only the Mint 18.1 to Mint 19.

    It’s possible the files are in the wrong location but I went step by step on the guide so I think I have them in place correctly.

    The error I am getting with that exact parameter is booting to emergency mode and using the one you created I am getting denied permissions for “/var/www/html/iso/mint/” which in my cases wasn’t a directory to start with but I made it just in case and tried changing the permissions from root to user and back with no differences. I changed that line to point to “/images/os/mint/19” and I now go back to the emergency mode issue.

  • @george1421

    Sorry for the late reply, was tasked with something else and didn’t get back to working on this before the weekend started.

    Here are the results of /images/os/mint/19
    Screenshot from 2019-02-04 09-19-25.png

    Thanks again. I’ll hopefully have some extra time to keep playing around with it.

  • @Gurf What is the exact error message? I’m a bit confused about your line:

     quiet splash

    Maybe the vmlinuz and initrd.lz are in the wrong location?

  • Moderator

    @Gurf From your fog server what does the output of this path look like?
    ls -la /images/os/mint/19

  • Moderator

    @Gurf So what does your imgargs line look like? Ugh its in your OP

  • Thank you for the reply George.

    Unfortunately it did not work in my case but it does give me some different results which I’m going to play around with.

    If I figure it out I’ll be sure to share.

  • Moderator

    Here is a link to a post by @Gamienator where he said that he had it working: I did not test to see if it worked or not, but I’m suspecting yes it works.

    Also be aware I may have missed another needed kernel parameter when I updated my post.