Computer not restarts/shutdowns after deploy



  • Hi.
    I have 40 new computers HP Prodesk G4 MT and I’m using kernel 4.15-2 because I’ve tried other kernels but they don’t work with those computers. All works fine and the image is deployed, but when it finishes the computer does not restart or shutdown. It remains with “System restarting” but never restarts and I have to restart it manually. Someone knows where is the problem?
    Thanks!



  • Hi!
    Thanks for your recommendations. Finally I’ve solved the issue with ```

    reboot=pci
    

    Thanks!!


  • Developer

    @robellet This is very likely to be a bug in the firmware if you can pin it down to a particular type of computer. As you already wrote that those only work with kernel 4.15.2 (for whatever reason, maybe you can tell us more about what failures you see with other versions?) it kind of suggests that those seems to be very picky.

    1. I would try to update/flash a new BIOS/UEFI firmware to hope things might be fixed in that. If you already have the latest firmware version on all those machines then we might start looking into what’s causing the hang from the kernel side. Be aware that you need to get into compiling the Linux kernel from source code (don’t worry, we have instructions on that) and maybe even make changes in the code. We can guide you there but as we developers don’t have access to that specific hardware you are the only one to test.

    2. Try setting the kernel parameter (FOG web UI -> Hosts -> select one of the hosts to edit the settings -> Host Kernel Arguments, e.g. to reboot=bios,force or reboot=acpi
      Here you find a explanation of the options. As mentioned you can combine the parameters like in the example above.

    3. If non of the above things help you might want to get some Linux live CD/DVDs and see what happens when you reboot those. Just burn the ISO on DVD and boot from it. Then see if the normal shutdown works or if it hangs as well. Here is a list of easy to use Live Linux DVD/CDs. Try different ones and see if it works or not:


Log in to reply
 

350
Online

5.8k
Users

13.2k
Topics

124.1k
Posts