ipxe Could not boot: No such file or directory



  • Server: Ubuntu 18.04.1
    FOG Version: 1.5.5

    The error received during client boot up:
    https://10.201.1.7/fog/service/ipxe/boot.php… No such file or directory (http://ipxe.org/2d0c613b)”

    I’ve confirmed that the file does exist on the server: https://imgur.com/a/HqnopId
    I’ve also confirmed that the “tftp pxe kernel dir” in the web gui is set to: /var/www/fog/service/ipxe (https://imgur.com/a/BhIjomC)

    Before this error, I was running into: “tftp request timeout”, which was remedied by restarting tftp on the server.

    Going to the webpage https://10.201.1.7//fog/service/ipxe/boot.php yields: https://imgur.com/a/WojVPk5

    Adding this just in case: I recently upgraded to 1.5.5 (https://forums.fogproject.org/topic/12863/webui-fog-configuration-page-displays-php)

    Any help would be greatly appreciated.


  • Developer

    @Reagan said:

    Are these commands something I need to run every time I upgrade the FOG server?

    Well that’s a good question. No, from my point of view, if you don’t recreate the certificates (extra installer parameters - shouldn’t use if you don’t know exactly what you do anyway) or move to use your own custom certificates (from an official or internal certificate authority), there is no need to rerun the build script.

    By the way, I opened an issue to include the build process to the installer, so this manual run won’t be needed anymore. This will be part of the next official release.



  • @Sebastian-Roth After running the commands on the server everything seems to be running properly. Are these commands something I need to run every time I upgrade the FOG server?

    Thank you very much!


  • Developer

    @Reagan said in ipxe Could not boot: No such file or directory:

    The error received during client boot up:
    https://10.201.1.7/fog/service/ipxe/boot.php… No such file or directory (http://ipxe.org/2d0c613b)”

    The error is a bit misleading, sorry for that. I have not figured out a way to get to a better error message yet. You installed using the force-https parameter. That is fine but for PXE booting to work with HTTPS you need to compile your own iPXE binaries that include the correct certificate. As the certificate is unique to your server we can’t simply ship the iPXE binaries as we do it for normal HTTP. To cut a long story short you just need to run these commands as root and should have it work then:

    cd /root/fogproject/utils/FOGiPXE/
    ./buildipxe.sh
    

    Note: After the build process it will call the FOG installer script again to put those new binaries into place.

    PS: As more an more people use HTTPS I will try to include the compile step into the installer for HTTPS installs.


  • Moderator

    Oh the other thing I would check is the apache error log in /var/logs/apache2 directory. These might give a better error message into why the file was not found. We may also need to review the php-fpm error log too. But lets see what apache has to say first.


  • Moderator

    I see you are using the https protocol. That is by intent? FOG uses http protocol by default.

    Second, can you provide a clear screen shot of the error taken with a mobile phone? It would be helpful to see the context of the error. I might understand why the error is at this point of the booting process because this would be the first reach out of the iPXE kernel attempting to get the FOG iPXE menu from the FOG server. I might think the https protocol was at fault here, but your other debugging steps are spot on.

    I do have to commend you on some of the other things you’ve done trying to debug this. These are all steps I would have asked you to take to get to this point. Well done.


Log in to reply
 

443
Online

6.2k
Users

13.6k
Topics

128.2k
Posts