Trouble Deploying Ubuntu 18.10 Image



  • I’ve been trying to set up a FOG server for my environment (which is entirely Ubuntu and CentOS), and I think I was able to capture the Ubuntu image successfully, but I am having some issues when I try to deploy the image. I’m new to using FOG and I’m not sure what I could do to fix the issues I’m having. Here’s a screenshot of the error message I get. Any help would be greatly appreciated.VirtualBox_Client 2_22_01_2019_12_21_37.png



  • @Sebastian-Roth I ended up fixing this issue myself. I had made an error in the capture process. I’ve got everything working properly now. Thanks for the help.


  • Developer

    @clafleur said in Trouble Deploying Ubuntu 18.10 Image:

    db_ root: cannot open /etc/target

    This message you can ignore! It’s not a real error and has nothing to do with your issue.

    Make sure you capture the image properly. Run ls -al /images/test on your FOG server after capture to verify the image files were created.



  • @Sebastian-Roth
    I thought I had captured successfully, but it looks like the size of the image says 0 and the date says invalid.

    Something interesting I noticed when I try to capture or deploy it says:
    db_ root: cannot open /etc/target

    I don’t know if that points to some known issue but I thought it might be worth noting.

    Apologies again if this is a stupid line of questioning. I really appreciate the help.


  • Developer

    @clafleur Have you ever captured/uploaded to the image called test successfully from another client? This is necessary before you can deploy the image!



  • @Sebastian-Roth said in Trouble Deploying Ubuntu 18.10 Image:

    cat /images/test/d1.partitions

    Thanks for the response. All of those commands return “no such file or directory”. I’m wondering if I did something wrong in the setup process.

    I tried following your other directions and got the same error.


  • Developer

    @clafleur Please run the following commands on your FOG server and post output here:

    ls -al /images/test
    cat /images/test/d1.partitions
    cat /images/test/d1.minimum.partitions
    cat /images/test/d1.fixed_size_partitions
    

    Just to see if the issue comes from the image type. Please create a new image definition (e.g. testtwo) and set it to "Single Disk Multiple Partitions - non-resizable. Set all the other options exactly like you have them in your test image. Then capture from the exact same machine as before and try to deploy this image to another machine. Do you get the same error?


Log in to reply
 

342
Online

5.9k
Users

13.2k
Topics

124.1k
Posts