SOLVED UEFI boot Instead of Bios boot

  • So here is what I have tried. I have tried to switch my settings on my DHCP Server 067 from ipxe.pxe to ipxe.efi, intel.efi, Realtek.efi, snp.efi, and snpoly.efi without any success. I either get iPXE is initializing devices and hangs or chainloading failed/ booting loop. The link below I think are my answers but want to make sure.

    Questions with this:
    UEFI boot will not work without these entries from link above?
    I have 066 and 067 setup already working with BIOS boot. Different computers I have had to tinker a little with this but not much. 067 had to change a few times. I don’t need both but can I use both BIOS and UEFI at same time? Explain if you can. Thanks
    These entries will be on a domain controller (2016) running DHCP so making changes, I am a little hesistant that will affect other things? So, will these entries affect anything with my current network/Server? Recommend backing up server before entering these? I see them as entries just for booting up with FOG but want to make sure. I am not an expert(feel I am just dangerous enough that I could get in trouble if not warned) and want to make sure all is covered before I make any changes.
    Anything else that anyone may find useful on UEFI boot up instead of BIOS. Still learning pros/cons and what benefits and how to use UEFI boot instead of BIOS. Any guidance is helpful. Thanks!!

  • Moderator

    @adukes40 said in UEFI boot Instead of Bios boot:

    @george1421 you doing that for every single uefi machine, or just the problem child’s?

    We do it for every machine that won’t init using iPXE in uefi mode. Which is only the o7010 so far.

    We also don’t pxe boot through fog to the hard drive. This is to avoid accidental reimaging systems. We always require a tech to sit in front of the system they are imaging and use the F12 boot menu to select pxe boot. Once a tech accidentally remotely deployed an image to the controllers laptop, that was enough motivation to change our workflow.

  • @george1421 you doing that for every single uefi machine, or just the problem child’s?

  • Moderator

    @adukes40 When I say forever, that means the time I was willing to wait until I said forget about it. I think one test was to leave it run overnight and it was still waiting in the AM. There is something in the uefi firmware that can’t be initialized by iPXE.

    The only solution I found for a uefi based system was to use the F12 boot menu and pxe boot in bios mode to deploy a uefi image to that target computer. Once the computer reboots after FOG it starts in uefi mode and starts WinSetup/OOBE.

  • @george1421 You say the 7010s will hang forever. I am on a 7010 that was hanging started looking around. When you say forever, do you mean it will never go thru, or forever as in it just takes a long time be will eventually go? I am currently running ipxe.efi

  • @george1421 Thanks for the info. I will look into some more settings on machine but think you are right on older hardware. I will keep you informed on newer machine I do next week. Thanks

  • Moderator

    @bmick10 said in UEFI boot Instead of Bios boot:

    Don’t you think I need these policies in place for it to work properly for UEFI? I mean ipxe.efi wouldn’t work without those policies in place would they?

    You only need the policies in place if you want to auto switch between uefi and bios boot files. If you manually want to manage dhcp option 67 you can do that. The policies just makes it automatic. When you look at the policies it will only send the fog pxe boot file names if the target computer matches a certain pattern. Otherwise the default boot file is sent.

    Now where you might run into issues is if you have a WDS or SCCM server in place, those servers will override the dhcp settings (by design). Or if you have voip phones on the same subnet as the pxe booting computers. If these voip phones auto provision from the PXE, some phones use dhcp netboot settings to find the pbx. If you then use the filters to set both dhcp 66 and 67 you can have both voip phones and pxe booting computers on the same subnet. I know its a bit complicated until you start working with pxe booting and understand how the parts fit together.

    As for helpful hints on uefi vs bios… Get use to uefi all newer hardware is coming uefi mode only. Some times you need to enable uefi pxe booting inside the firmware to turn on pxe booting. You will need this for some Dells (enable uefi network stack).

    I can tell you if you can see the iPXE banner then pxe booting is working. Once iPXE boot kernel is transferred to the target computer pxe is no longer used.

  • @george1421 One is a lenovo 11E laptop and other one is HP4300 Small form factor desktop but I don’t have any of those policies in place yet. I just wanted to make sure the policies don’t affect anything else on server/network before we implemented. These are old computers and we will test on a brand new computer next week. I didn’t have access to the newer computer until next week so figured I would test and see what happened on what I had. Don’t you think I need these policies in place for it to work properly for UEFI? I mean ipxe.efi wouldn’t work without those policies in place would they?

    If we continue to use BIOS for a while on other devices is it just a switch on 067 when I want to do a boot up? Don’t want to make too complicated just wondering if can work at same time? If you don’t recommend that is fine.

  • Moderator

    First let me say I have these settings (from the coexistence document) on my 2016 dhcp server and they work correctly with out an impact.

    The instructions guide you on how to create a policy and matching filters. So only when the computer with the match to the filter boots, the policy will be applied, if there is no match to the filter then it sends what ever is in the default dhcp options 66 and 67.

    Now in your case, for uefi you would typically use either (for uefi) ipxe.efi or snponly.efi. The other .efi are for special use cases. Since your hardware is hanging during the boot if ipxe.efi there is most likely an issue with your hardware or uefi firmware on your target computer.

    I can tell you for a fact if you have a Dell 7010 in uefi mode, it WILL hang at the ipxe screen for initializing devices (forever).

    What hardware are you trying to pxe boot? If its Lenovo I’m going to suggest that you update your firmware (bios) to the latest.