WebUI Fog Configuration page displays php


  • Developer

    @Reagan Ok, the web directory structure looks ok. I expected that to be an issue but it’s fine. Still I really wonder why you have 1.5.4 in the bottom right corner. Please run the following commands and post results here again:

    find /var/www -type f -exec grep "FOG_VERSION" {} /dev/null \;
    tail /var/www/html/fog/lib/fog/system.class.php
    


  • Here are the outputs/pictures as requested.
    https://imgur.com/a/5ul6o6T


  • Developer

    @Reagan said in WebUI Fog Configuration page displays php:

    Something I noted was although it reflects in console, upon logging into the WebUI at the bottom right it displays “Version 1.5.4”.

    Just saw this in your initial post. I am fairly sure there is something wrong with your installation. Please run ls -al /var/www /var/www/html /var/www/fog on your FOG server (note there are spaces between the paths!) and post output here.

    I’ve just checked my test installation with Ubuntu 18.04.1 and the configuration page is perfectly fine. I can’t really imagine what would cause only this single one page to be shown as PHP code. It’s all rendered through the same framework. Could you take a picture of that an post here? If you can’t upload the pic in the forums directly, then upload to a picture share host and post a link here.



  • It is running Ubuntu 18.04.1 LTS (GNU/Linux 4.15.0/43/ Generic X86-64).
    This issue is only taking place on the Fog Configuration page, every other page is functioning properly.


  • Developer

    @Reagan Which Linux OS do you use? Any other page that shows the PHP code? This is very strange!

    PHP Notice: A non well formed numeric value is encountered in /var/www/fog/status/bandwidth.php on line 109

    This is known and fixed in the dev-branch, going to be in the next release.


Log in to reply
 

422
Online

6.1k
Users

13.4k
Topics

126.3k
Posts