SOLVED Fog imaging and M.2 drives

  • Hello.

    We are running Fog on Ubuntu 18.04.1 LTS as a VM on Server 16.

    Imaging works amazing with regular SATA SSD drives using the 4.15.2 Kernel. However, when imaging newer machines with an M.2/NVMe imaging drops the speed down from the normal 4-5GB/m to 1GB/m or less compared to imaging a machine with a SATA SSD. I’ve tried a newer kernels and they all hang at clearing the MBR/GPT table and go no farther.

    Ill be monitoring for any other requests for information. Thanks in advance!

    Machine specs are as follows.

    Dell OptiPlex 7060
    Intel i7-8700
    Dell 1.1.4 7/10/2018 BIOS
    16GB DDR4 2666Mhz
    Intel NIC (7) i219-LM
    Intel NVMe M.2 256GB SSDPEKKF256G8

  • Senior Developer

    @dirtrunner21 Almost forgot to tell you that you need to upgrade all your nodes if you go from 1.5.4 to 1.5.5 or dev-branch. See the release notes on 1.5.5!

  • Senior Developer

    @dirtrunner21 Just a quick note for you. We already found and fixed an issue with snapin replication that exists in 1.5.5 - so if you are heavily using snapins on storage nodes I recommend you directly go to use the dev-branch or wait for 1.5.6 (not sure when we get to release this).

  • @Quazz I will be upgrading the server this week and I will report back!

  • Moderator

    @dirtrunner21 I’d be interested to see if the speed improves any on the latest kernels. I do think it’s some kind of kernel/firmware issue (that being said, the kernel configs seem to already have all recommende options enabled/disabled as needed), although this one in particular isn’t nearly as bad as some others (some reaching only 8mb/s under certain conditions)

    Worth checking out an update to FOG 1.5.5 (which will automatically pull latest kernel and binary)

  • Thank you both for the replies and the information!

  • Moderator

    I recall certain SSDs getting inexplicably low speeds.

    Here’s the discussion about it on the partclone github page:

    Currently not solved and obviously a pretty big problem if you’re experiencing this.

    Only info I’ve found myself is about 32 bit kernels on systems with 4GB+ RAM causing this issue.

    Some older topics suggest the DMA is sometimes disabled on SSDs for some reason.

  • Senior Developer

    @dirtrunner21 said in Fog imaging and M.2 drives:

    I’ve tried a newer kernels and they all hang at clearing the MBR/GPT table and go no farther.

    This issue is known and fixed. Either update to 1.5.5 or manually update kernel and init.xz! Search the forums and you should find numerous posts on how to do that.