SOLVED Fog using dhcp and dns from exisiting network

  • I have read over the wiki on how to get this working on an existing network and having some issues. I know we are using cisco routers and we have things pointed correctly.

    I am able to boot up and it grabs and Ip address and then all the other information. It just fails at pxe.

    I have an ip address, subnet mask , and gateway.

    error is

    pxe-e32 tftp open timeout
    pxe-m0f exiting intel boot agent.

    If i could paypal someone to look into the server to make sure it is correct I am willing to do that. I just want to make sure i have that part setup. I normally only do this on an isolated network and have no issues.

  • Thank you everyone for your help. I had networking team move to same vlan and it worked fine. Then i had them move to seperate vlan and use wireshark. I found out we had sccm pxe setup. This was done long time ago. No one removed the forwards on the router.

    Now we have it working once we removed the entries.

  • Moderator

    @mmoore5553 With the client on a different subnet as the fog server then running the commands on the fog server side will only tell us half of the story.

    So for the client on the other subnet, you will need to use wireshark on a computer on the same subnet as the pxe booting computer (or take a linux computer and use the tcpdump commands from the tutorial). Have that wireshark system use the capture filters of port 67 or port 68 to capture the dhcp messages only. This will tell us what your dhcp server is telling the pxe booting client to boot.

  • Thank you all for replying. I will have to look at this on monday. I know the fog server and the client are on different subnet. I will have to work with our networking team to get at least one computer on the same subnet. Once i am on the same subnet i will go ahead and run your tests.

    Thank you so much. I have never joined an existing network so it is all new to me. I will grab captures once that happens.

    stay tuned.

    I was able to manually download a file from the TFTP server when i was logged into my windows machine. I used tftp -i x.x.x.x get undionly.kpxe. It successfully downloaded the file. So i know the services were up and running.

    it is when i try to pxe boot is when i run into issues. It is on seperate vlan.

  • Verify that a host on the same subnet is able to manually access the tftpd server. Make sure a host on the other subnet is able to manually access the tftpd server (including downloading the boot file both times!). If both of these work, then its figure out funky stuff. If either fail, you gotta figure out what’s incorrect on your config.

  • Moderator

    If your fog server, dhcp server and pxe booting clients are on the same subnet/vlan then we can use the fog server to capture what is going on with the pxe booting process. You can follow the instructions here:

    Upload the pcap here, or to a google drive and post the link here. There was an issue before the holidays with uploading to the fog forums, so you may have to go the google drive route. We’ll take a look at the pcap can tell you what’s missing in the startup sequence.

  • Senior Developer

    @mmoore5553 We need more information to be able to help! What is your DHCP pointing to? Is it pointing to the FOG server IP? Is TFTP running on your FOG server (run netstat -antup | grep ":69" and post here)?

    Please go through the troubleshooting guide to see if you can manually download via TFTP: