UNSOLVED Windows Could Not Finish Configuring the system Error (1809)

  • Currently running: FOG 1.5.4

    So I am trying to build a generic Windows image for the next school year, following the same guides I used to do this last year. However, when the image is deployed through FOG (sysprep and capture look good) I get the error that “windows could not finish configuring the system”. I know this is a common issue with the FOG service (so to be sure I removed the client all together). However, I am still getting this error when Windows is setting up. I was wondering if anyone here had any other ideas what might be causing this issue? Bad answer file maybe and this isn’t a FOG issue at all? Was hoping maybe someone here could help me figure out where I am going wrong.

    My answer file
    customize .txt

  • I think I hunted down the culprit. I installed each piece of software one at a time and it looks like it is the new cloud version of Sophos that is giving me the error. Removed it from the image and everything seems to have went through without an issue.

  • Moderator

    @jveronese The setup logs should give you an idea why its failing. I can also say I havn’t built a 1809 reference image yet (still waiting for a stable release) but unless MS has changed something when its sitting at the Could not finish configuration message, if you press ctlr-F10 (or Alt-F10) you should get a command prompt. You can then navigate to the log file directory and copy over the log files to a flash drive.

    (ok this one is a bit fuzzy since its been a while)Also (at least with Win7) you can call up regedit and then go hklm/setup and change the setup state to zero. Then reboot the target computer. Windows is NOT completely setup at this point, but it should allow you to review the files ON the target computer.

    [edit] here is a document that describes the actual path of the registry key: https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/windows-setup-states

  • What sysprep command are you running?

    Also, use Windows System Image Manager to validate your answer file

    Also, remove ALL comments from your answer file, ESPECIALLY the first 11 lines of comments, if sysprep sees comments on line 1 it causes issues.

  • Still having the issue. If it is a driver issue is it possible that the drivers from VirtualBox’s guest additions are the cause?

  • Sorry, yes it is Windows 10 version 1809.

    I have tried not installing the FOG client at all as well as trying other people’s answer file. I am thinking the issue might be caused by installing Windows ADK, so I am starting from scratch to see if that is where the issue is. Will update if it works.

    Thanks everyone!

  • Moderator

    @jveronese Is that Windows 1809 or system error 1809? I’m suspecting is Windows 10 release 1809. FWIW that release was pulled from deployment from MS several times. The last I heard is that they will release a fixed, release of the last release sometime soon. Make sure if you are building your golden image, to use the latest release (Dec 2018).

    The error you mention I have see before on several occasions.

    1. A device driver failed to install and caused the system to reboot unexpectedly.
    2. You had the fog service installed, but failed to heed the instructions to disable the service before image capture and then reenable it in the startupcomplete.cmd file. If you failed to disable it before sysprep, the fog service is starting too early in the oobe process causing the system to reboot before oobe is done.

    Windows does log things pretty well. On the target computer, inspect the logs in c:\windows\panther to find out what happened and why windows couldn’t finishing. It easiest if you add the failed hard drive as a second hard drive in a working computer to get access to these logs.

    Did you happen to remove any windows built in applications (crapware)? I’ve also see removing the wrong package cause oobe to fail on setup. With the exception of the fog service not being set to manual startup, this error is typically not related to fog at all.

  • Most often this is not FOG related at all, rather a misconfiguration in your answer file. As to what, I don’t know.

    What Windows are you using?

    What else have you tried?