PXE Booting Issue



  • Hello everyone!

    When attempting to PXE boot, I receive a message that says “Either DHCP failed or we were unable to access http://192.168.1.163/fog//index.php for connection testing.” No, the extra / is not a typo, it does say that. I have no idea if it is an incorrect config file somewhere, etc. I know that DHCP is not the issue as clients can get an IP and get to this screen perfectly fine, and there are 300+ devices already running on a few scopes from the DHCP servers. Any help is greatly appreciated!



  • Hi @cmyron . I had the same issue until i upgraded the kernel version to 4.5.0
    Maybe you can try it as well?


  • Moderator

    @cmyron Well the picture speaks volumes.

    Its failing inside FOS, so that tells us PXE booting, iPXE and FOS loading isn’t the issue. Its also not a spanning tree issue.

    I can see FOS getting an IP address and attempting to contact the FOG server. What I find a bit telling is the client is picking up an IP address of 192.168.1.160 and trying to contact the FOG server at 192.168.1.163. Which I might suspect is in the dhcp range since this target computer is 3 IP addresses away. So that kind of gives me the idea that your FOG server’s IP address may have been assigned by dhcp when FOG was installed, AND at some point in time the IP address of the FOG server has changed since FOG was installed (only a swag guess).

    Can you confirm that the FOG server is still at IP address 192.168.1.163 and you can ping it from a computer plugged into that same network port as the pxe booting computer?




  • Moderator

    @cmyron Yes, there is something not right with the forums, I think the update broke uploading pictures and files. Please upload to a publicly shared google drive, dropbox or picture bin site and post the link here.



  • @george1421 Alright now I just look like an idiot because the pictures are not uploading. Any advice?



  • @george1421 I am working on attaching the picture right now. I have tried a dummy switch and still the same issue. All of our switches support RSTP as well, and I havent had this problem until the most recent FOG release.


  • Moderator

    @cmyron Can you post a clear picture of the error taken with a mobile phone? The context of the error is almost as important as the error itself.

    My intuition is telling me its a spanning tree issue, but it depends on where exactly this message appears. A spanning tree issue can be diagnosed by placing a dumb (unmanaged) switch between the target computer and the building network switch. If it boots and images correctly then its most likely a spanning tree issue, where the port isn’t using one of the fast stp protocols.


Log in to reply
 

460
Online

6.2k
Users

13.6k
Topics

128.1k
Posts