SOLVED Issues Tasking imported hosts in a group

  • Having issues getting single snap-ins to task on hosts that have been added via csv import on fog 1.5.5. i can deploy snap-ins to them individually but when ever i try to deploy the snapin to the group im left with blank screen. any ideas?


  • Senior Developer

    @bmorine Sorry, I lost track of this in the busy time before X-Mas. I found and fixed this issue in the dev-branch so this will be part of the next release. If you want to use it beforehand feel free to switch to the dev-branch.

  • Senior Developer

    @bmorine Seems like I was wrong here. Snapins obviously have changed a little bit since I last have worked on this. Probably Tom knows more about this. So for single hosts you are now able to run snapins that are not associated with it (this is news to me, wasn’t like that all the time). From this point of perspective I totally understand that it’s very confusing that you can’t do the same in a group.

    I will look into changing the code that it behaves same for single hosts and groups.

  • Senior Developer

    @bmorine Now as I have tested a bit more I can see what you mean. The thing with this is that groups in FOG don’t hold persistent settings but are only a tool to push settings to the host objects. So if you create a group and add the host members you still need to assign the snapin from the group to the hosts (or manually for every host) so the snapin is associated to the host object. Then only you are able to run the snapin on those clients.

    I know that this might be unexpected behavior and not showing a message (empty page) is not perfect. I am thinking about how we can improve that. But from the group not being persistent in FOG perspective this is all intended behavior!

    Also thanks for posting the apache logs. I found another minor issue that I already fixed. Those messages shouldn’t fill up the logs for no reason. Fix will be in the next release.

  • Senior Developer

    @bmorine I am sorry we’ve left you with this but I have not found the time to really look at it yet.

    assigned the snap-in to hosts in group temporarily and then tryed deploying the snapin and it worked.

    You mean assigning the snapin to each host individually by hand? Did you deploy for the whole group or as well individually for each client?

  • assigned the snap-in to hosts in group temporarily and then tryed deploying the snapin and it worked.

  • tried registering hosts via pending host list as well and ran hardware inventory task on host after. same issue… happens on all 7 of my servers. i’
    m a little new to fog is there something i’m doing wrong?

  • This post is deleted!

  • This post is deleted!