Unable to locate image store



  • Hi all,

    With all your help, I finally managed to install the fog server and put all my images on it. However, when I boot to the pxe menu and want to deploy a image, I get the following error: Unable to locate the image store

    I double checked the following:

    • The default storage is on and enabled
    • the images are located on my disk on /images
    • Every menu item I can see is linked to /images
    • There is a image about 10gb in size

    I have no idea what to do. Will post the error log tommorow when I get back to the shop, but I will take any suggestions now :)

    Thanks!


  • Developer

    @iekozz I am not too sure where we are at with this multi culti topic here. I’ve just read the whole lot again. We started by fixing your image name possibly along with some other image settings, then got the non bootable media error (FOG is not able to transfer the UEFI firmware boot entries from one machine to another yet!) and talked about timezone and FTP issues.

    May I kindly ask you to open a new topic and explain the current issue you are seeing at the moment. We’ll focus on fixing that and move on from there (probably in just another topic). The less we mix up topics the more other people can profit from the things we find out and write to fix their own issues.

    So I am marking this solved now as we have solved the initial issue (and more). Please open a new topic and explain where you are at.



  • @Sebastian-Roth Alright, i’ll test the ftp server. So best not to mess with any of the passwords, just leave everything at default., don’t want to break it :).

    Digged around to find a logfile so I could see what was causing the issue, just have not found it yet. Is that in a config file? Found the imaging log, but that just says the duration and the image used.

    Btw, I also figured out what was causing the no boot device errors. The image does not link the new install with the efi.boot file. When I linked it in the bios, it all works. Should I update the host bios exit type and host efi exit type and then make a new image? 0_1543311792378_2ec0b5f7-f534-4887-93a1-4a540e6fd05d-image.png


  • Developer

    @iekozz said in Unable to locate image store:

    Change that this is not displayed in the installer or you can choose it somehow.

    You should not use that fog Linux account at all! It’s FOGs service account and you shouldn’t need to mess with it. This is why we don’t prompt you to change the password (it’s very strong auto-generated). Don’t use that account to login and work on the machine.

    Ok, so I can just change the password from the terminal and then enter that password everywhere in the ftp settings?

    Yes it is possible to change but I would not advice you to do so. If you still want to you need to change that in various places like /opt/fog/.fogsettings, /var/www/html/fog/lib/fog/config.class.php, Web Interface -> FOG Configuration -> FOG Settings -> TFTP Server -> FOG_TFTP_FTP_PASSWORD, Web Interface -> Storage Management -> DefaultStorage -> Management Password (That’s just a quick list from the top of my head, unsure if I missed something)



  • @Sebastian-Roth Ok, so I can just change the password from the terminal and then enter that password everywhere in the ftp settings?

    Strange that this is not displayed in the installer or you can choose it somehow.


  • Developer

    @iekozz The account fog is create by the FOG installed and should not be touched.

    Password reset is done as usually in Linux passwd fog. But if you change the password FTP will cause issues which is used in the background.



  • @Sebastian-Roth Now that you mention it, there is another user on my fog server, named fog. I’ve never set-up a password for that account though? Where can I find/change it?


  • Developer

    @iekozz said in Unable to locate image store:

    Only thing I have not tested it a test file to send to the ftp server.

    Please do exactly that to see if you really have the right credentials. From what you said I have the feeling that we are talking about different things. The installer creates a web interface user called fog but that is not the same. The FTP user fog is a local Linux account and has a different password set. A longer random password not displayed by the installer.

    The one thing I did notice though is that when the image capture is done, it can’t update the database because the utc time is not set (or something like that) could that be it?

    Could play a role. See here: https://forums.fogproject.org/topic/12036/centos7-fog-1-5-3-image-capture-fails-with-incorrect-date-timezone-info/2



  • @Sebastian-Roth I see the password I made at the installation, never changed a thing from the default. I see my password in those two files, they are the same, or do you mean the mysql password? I left that blank, easier for me.

    Did some further digging:

    1: ftp password is set in the tftp settings and my storage settings
    2: ftp path is set to /images
    3: everything is owned by the fog server
    4: the firewall is allowing all traffic
    5: the ftp service is running

    Only thing I have not tested it a test file to send to the ftp server. The one thing I did notice though is that when the image capture is done, it can’t update the database because the utc time is not set (or something like that) could that be it?


  • Developer

    @iekozz said in Unable to locate image store:

    Also, when I make a new image, the folder is not created under /images, it does save it somewhere, no idea where.

    This is a different issue. Images are stored in subfolder in /images/dev/… named like the client MAC address. The folder should be renamed/moved to /images/<IMAGENAME> after it finished uploading. As this does not happen I am fairly sure your FTP connection is not setup properly anymore. The installer does this for you but if you changed the fog user password it will cause that kind of problem. Do you know that user’s password? See if it matches the one you have in the config files /var/www/html/fog/lib/fog/config.class.php and /opt/fog/.fogsettings



  • @Sebastian-Roth Yes, on the same machine. Also, was using a different pc (Dell optiplex 990) and even when deleting all the data, it fails with a non boot device found error. But it does copy everything to disk.

    This is a uefi system using a uefi image.

    Also, when I make a new image, the folder is not created under /images, it does save it somewhere, no idea where.


  • Developer

    @iekozz said:

    When i delete everything from the disk, it works, and starts windows.

    Have you tested this on the very same machine? I kind of doubt as we do clean the partition tables as well.

    Sounds like an issue where differences in machines play a role. Lets start with the obvious, are both machines legacy BIOS setups or UEFI or mixed?



  • @Sebastian-Roth Here is what I do.

    1: start fog pxe menu
    2: deploy image
    3: fog starts image process and completes
    4: when the pc reboots, it displays a message with no bootable devices found.

    This happens if there was another windows install on the disk. Even though it is deleting the tables when imaging.

    When i delete everything from the disk, it works, and starts windows.


  • Developer

    @iekozz said in Unable to locate image store:

    If data is on the drive, it returns a error with non bootable media found.

    What do you mean by that? Explain in more detail.



  • @Sebastian-Roth thanks, got it fixed by renaming the folder. I tried to image it and that worked, but it only boots on drives without data on it.

    If data is on the drive, it returns a error with non bootable media found.


  • Developer

    @iekozz said in Unable to locate image store:

    I have several images, so kinda weird to point to one image folder? Or just move them all in one big folder?

    In FOG each image needs to be in a separate subfolder residing in /images/<IMAGENAME> plus a matching image definition in the web UI pointing to exactly the right path. In the output you posted I can only see one single image that is complete to be used. The paths did not match and so I suggested to correct that either by renaming the path in filesystem or in the image settings. As well you have a couple of images in subfolders in /images/dev sitting which were not fully uploaded. That’s another story to be told. Let’s try to get that one single image to deploy again and then move on.



  • @Sebastian-Roth Ah yes, I really need my glasses ;-)

    I have several images, so kinda weird to point to one image folder? Or just move them all in one big folder? Will change it from partimage gzip, thanks for the tip. Here is the picture you requested:

    0_1542835096852_4631c8b3-fd41-4ac1-9412-8203c784ed25-image.png


  • Developer

    @iekozz Again not correct to the point (upper case L vs lower case l) but that’s not an issue this time. I think we have enough information now.

    First I see the .mntcheck files which I thought might be missing. So I was wrong.

    Then I see:

    /images/Win10uefi:
    .   d1.fixed_size_partitions  d1.minimum.partitions  d1.original.swapuuids  d1p1.img  d1p3.img  d1.partitions
    ..  d1.mbr                    d1.original.fstypes    d1.original.uuids      d1p2.img  d1p4.img
    

    While in the picture the image path is /images/Windows10v1809UEFI. So either rename that folder in the filesystem to match the setting in the web UI or the other way round.

    Plus I noticed that you have “Image Manager” set to “Partimage”. I kind of doubt you created this image using the very old Partimage tool (used in FOG years ago). Probably set this to “Partclone GZIP” but that’s just me guessing here.

    I also made some screenshots on my settings. I also noted that the default storage is linked to eth0, but when I check with ifconfig -a it’s linked to p2p1, seems it’s not finding it because it’s using the wrong network interface?

    Could be but I don’t see all the important information in the picture to be sure. Post the top part of the storage node setting as well so we see the IP is matching the one we see in ifconfig.



  • @Sebastian-Roth Ah, you’re right, whoops. Here is the output:

    [fogserver@localhost ~]$ ls -aLR /images
    /images:
    .  ..  dev  .mntcheck  postdownloadscripts  Win10uefi
    
    /images/dev:
    .  ..  0800271fe49c  080027aff8e3  080027c3f4a4  782bcb83d2b0  .mntcheck  postinitscripts
    
    /images/dev/0800271fe49c:
    .   d1.fixed_size_partitions  d1.minimum.partitions  d1.original.swapuuids  d1p2.img
    ..  d1.mbr                    d1.original.fstypes    d1p1.img               d1.partitions
    
    /images/dev/080027aff8e3:
    .   d1.fixed_size_partitions  d1.minimum.partitions  d1.original.swapuuids  d1p1.img  d1p3.img  d1.partitions
    ..  d1.mbr                    d1.original.fstypes    d1.original.uuids      d1p2.img  d1p4.img
    
    /images/dev/080027c3f4a4:
    .   d1.fixed_size_partitions  d1.minimum.partitions  d1.original.swapuuids  d1p2.img
    ..  d1.mbr                    d1.original.fstypes    d1p1.img               d1.partitions
    
    /images/dev/782bcb83d2b0:
    .  ..  d1.fixed_size_partitions
    
    /images/dev/postinitscripts:
    .  ..  fog.postinit
    
    /images/postdownloadscripts:
    .  ..  fog.postdownload
    
    /images/Win10uefi:
    .   d1.fixed_size_partitions  d1.minimum.partitions  d1.original.swapuuids  d1p1.img  d1p3.img  d1.partitions
    ..  d1.mbr                    d1.original.fstypes    d1.original.uuids      d1p2.img  d1p4.img
    
    

    I also made some screenshots on my settings. I also noted that the default storage is linked to eth0, but when I check with ifconfig -a it’s linked to p2p1, seems it’s not finding it because it’s using the wrong network interface? Can’t check now, not at work anymore.

    [fogserver@localhost ~]$ ifconfig -a
    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
            inet 127.0.0.1  netmask 255.0.0.0
            inet6 ::1  prefixlen 128  scopeid 0x10<host>
            loop  txqueuelen 1000  (Local Loopback)
            RX packets 93585  bytes 70082869 (66.8 MiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 93585  bytes 70082869 (66.8 MiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    p2p1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 192.168.2.122  netmask 255.255.255.0  broadcast 192.168.2.255
            inet6 fe80::3ba2:61b4:1954:f66e  prefixlen 64  scopeid 0x20<link>
            ether d4:be:d9:de:5b:ac  txqueuelen 1000  (Ethernet)
            RX packets 86165  bytes 25189476 (24.0 MiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 113615  bytes 35423513 (33.7 MiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    

    0_1542823144617_fogstoragesetrtings.png
    0_1542823155895_fogimagesettings.png


  • Developer

    @iekozz Please run the command as suggested, you missed a hyphen…


Log in to reply
 

415
Online

6.3k
Users

13.7k
Topics

129.0k
Posts