SOLVED UEFI chainloading failed for SAN device

  • I’ve seen many chainloading topics with UEFI but none of the solutions in those topics have helped resolve my situation that I’ve seen. Here is the situation. If I have an image prepped to either upload or download then the pc will see it and upload or download with no issues. If there is no image prepped to send then the chainloading error will occur. I error I get is “Boot from SAN device 0x80 failed: Error 0x3f142083”
    “Could not boot: Error 0x3f142083”
    “Could not boot: Error 0x3f142083”
    Chainloading failed, hit ‘s’ for iPXE shell; reboot in 10 seconds.

    That line does repeat twice on my screen. I don’t know what error logs to look at as to why this is happening. I just need some guidance on how I can resolve this issue.

  • This was weird but I think it’s solved now. It didn’t matter which method I chose it would always give me the SAN error. I decided to reboot the server after current images finished. Then the error messages started to change. This now works with the REFINED_EFI method. I’m not sure why it didn’t want to update the method I chose but updating the server seemed to have kick what was stuck in it’s settings.

  • Moderator

    @jamesb Which version of FOG do you use? Is this an official iPXE binary provided by FOG or did you compile one yourself?

    I’ve tried GRUB, EXIT, and REFINED_EFI. All of them, except REFINED_EFI give me the same error.

    That’s pretty much impossible as the errors/codes you posted seem very much related to SAN boot. So please take the time and try all of them again but this time take a picture of the error and post all pictures together with according labels here.

  • I have tried some yes. I’ve tried GRUB, EXIT, and REFINED_EFI. All of them, except REFINED_EFI give me the same error. REFINED_EFI tells takes me to it’s own menu where it basically says please press enter to reboot the machine.

  • Moderator

    @jamesb Have you tried different exit styles yet? See the host’s settings in the web UI.