Intermittent Connection time out error.



  • I have installed latest FOG imaging server on both Virtual BOX and standalone server, however I am running into issues when trying to PXE boot client machines.

    It sometimes boots to the PXE menu and everything is fine but then when I try to run it again on same machine I get a connection time out error. I am using DHCP and DNS from the FOG service.

    I have tried different kernels and the same thing happens.



  • @george1421 Thank you thank you!!! that worked you are a legend mate ! Its all running!


  • Moderator

    @steharv Be sure to use my example completely and not just edit your ltsp.conf file to match. My config file is known to work correctly.

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,<fog_server_IP>
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # inspect the vendor class string and match the text to set the tag
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    
    # Set the boot file name based on the matching tag from the vendor class (above)
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI,ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI64,ipxe.efi,,<fog_server_IP>
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
    
    dhcp-range=<fog_server_ip>,proxy
    

    Be sure to replace each instance of <fog_server_ip> with the IP address of your fog server. There are several instances of that tag in the config file above.

    The last bit is to ensure you have the correct version or later of dnsmasq or the config file will not work. From the linux command prompt key in dnsmasq -v. The version returned should be 2.76 or later. If its earlier than this you will have issues with uefi systems even if you use my config file exactly.



  • @Sebastian-Roth

    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    Set the boot file name based on the matching tag from the vendor class (above)
    
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI,ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI64,ipxe.efi,,<fog_server_IP>
    PXE menu. The first part is the text displayed to the user. The second is the timeout, in seconds.
    
    pxe-prompt="Booting FOG Client", 1
    The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    This option is first and will be the default if there is no input from the user.
    
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
    
    dhcp-range=192.168.1.248,proxy
    

    Mod Note: Fixed file formatting -Geo



  • @Sebastian-Roth said in Intermittent Connection time out error.:
    nit dnsmasq.service has begun starting up.

    Nov 14 12:45:23 ste-VirtualBox dnsmasq[2453]: dnsmasq: syntax check OK.
    Nov 14 12:45:23 ste-VirtualBox dnsmasq[2454]: dnsmasq: failed to create listenin
    Nov 14 12:45:23 ste-VirtualBox dnsmasq[2454]: failed to create listening socket
    Nov 14 12:45:23 ste-VirtualBox dnsmasq[2454]: FAILED to start up
    Nov 14 12:45:23 ste-VirtualBox systemd[1]: dnsmasq.service: Control process exit
    Nov 14 12:45:23 ste-VirtualBox systemd[1]: dnsmasq.service: Failed with result ’
    Nov 14 12:45:23 ste-VirtualBox systemd[1]: Failed to start dnsmasq - A lightweig
    – Subject: Unit dnsmasq.service has failed
    – Defined-By: systemd
    – Support: http://www.ubuntu.com/support

    – Unit dnsmasq.service has failed.

    – The result is RESULT.
    Nov 14 12:45:23 ste-VirtualBox sudo[2447]: pam_unix(sudo:session): session close
    Nov 14 12:49:44 ste-VirtualBox sudo[2828]: ste : TTY=pts/0 ; PWD=/home/ste
    Nov 14 12:49:44 ste-VirtualBox sudo[2828]: pam_unix(sudo:session): session opene
    lines 2203-2225/2225 (END)e


  • Developer

    @steharv said in Intermittent Connection time out error.:

    journalctl - xe

    Then run that command and post output here. As well post your full config here.



  • @Sebastian-Roth I have tried restart dnsmasq but get the following error" Job for dnsmasq. service failed because the control process exited with errror code. See "systemctl status dnsmasq.service and “journalctl - xe” for details.



  • @Sebastian-Roth Thank you


  • Developer

    @steharv said in Intermittent Connection time out error.:

    Would I be better off just installing DNSMasq?

    You probably would. Follow George’s post here (full config file) and check your dnsmasq version: https://forums.fogproject.org/topic/12133/fog-on-existing-dhcp-server/3



  • @Tom-Elliott Would I be better off just installing DNSMasq?





  • @Tom-Elliott I cannot see any settings in my router for that?



  • @Tom-Elliott So editing the fogsettings file and rerun the installer? Can I edit the file via FTP?


  • Senior Developer

    @steharv In your Router you should have a method to set options for Boot IP and Boot file. It’s here I would recommend updating things. In MS DHCP the options are 66/67 (66 being the FOG Server’s IP/67 being the bootfile - ipxe.pxe, undionly.kpxe, etc…)


  • Senior Developer

    @steharv Then the problem is you have two DHCP servers on your network. This is why you’re getting access to FOG iPXE menu intermittently. Both DHCP servers are on the same network, and BOTH are issuing IP’s in the same subnet. If FOG hands out faster than the router, you’ll be able to get to FOG iPXE Menu, if not you’ll get an error.

    I’d highly recommend looking into manually updating the information.



  • @Tom-Elliott Hi Tom, I reinstalled FOG from scratch, I set the FOG server IP to 192.168.1.248 and then DHCP and DNS server the same IP but it still tries to look for 192.168.1.1 when it boots?



  • @Tom-Elliott Router is just set to default DHCP setting which is on and when installing FOG I answered yes to use FOG as DHCP server. No storage nodes, I can just reinstall FOG as can go back to a preinstall snapshot on VB.


  • Senior Developer

    @steharv Once you update the IP Address in the fogsettings file, rerun the installer. I’m also going to guess that you may need to update your storage node information.

    On a secondary note, is your FOG Server providing DHCP as well as your main Router?



  • @Tom-Elliott 0_1542118484332_router.PNG

    Attached is my default ISP router, just wondered if anything here is interferring?


  • Senior Developer

    @steharv Then I would highly recommend you update the IP address in /opt/fog/.fogsettings to match that of your FOG IP Address.

    Right now it’s looking at your router for the file, and it should be looking at your FOG Server for the default.ipxe file.


Log in to reply
 

366
Online

5.8k
Users

13.1k
Topics

123.1k
Posts