Fog on Existing DHCP server



  • Hello, i am installing FOG for the very first time, i had chosen centos at the begining, but i then watched a tutorial online and he used kubuntu, so i am now using that to install fog.

    Since i have a DHCP server that is provided by my router, i chose fog server not to use it’s DHCP server, but when i install it says that i should enable option 66 or 67 and forward it to my fog server ip address etc etc…
    The thing is… i don’t have that option on my router, and i am not using a dhcp server on linux or windows.

    I am stuck, what should i do? creating a firewall with pfsence is allways an option, but i am trying to figure out how people would do this with a simple modem/router



  • @Sebastian-Roth Hi Sir I will do so thnx


  • Developer

    @TechWiz It’s probably best if you open a new topic and tell us more about you setup. What kind of DHCP server, FOG version, VLANs?, etc.



  • Hi George1421

    Thanks for the pxe update.

    With this change what other changes do you need to make with the fog server default install.

    Thx



  • well… got pfsense and fog already is booting into his pxe menu. Thanks!
    I am now reading the rest of the tutorials you mentioned so i can get ahead and configure this awsome server.
    many thanks George!


  • Moderator

    @vascomorais said in Fog on Existing DHCP server:

    is there a way i could reach my pxe boot from the exterior?

    From some place else on the internet? In concept, yes. But you would open both your fog server and target computer up to compromise. Also you would need to configure the remote dhcp server to point/load the boot file from your fog server, plus your fog server would need to have an internet addressable IP address.

    Generally, its possible but a bad idea for security reasons.



  • uhhh, nice, i have been configuring pfsense to replace my router, but i am stuck with a weird issue.

    • non related fog project stuff here –

    begin
    After configuring all the corresponding vlans for GPON, IPTV and VOIP, i get an ip that doesn’t lead to the internet, and i don’t know why, usualy vodafone ip’s start with 89. something, i was getting an ip starting with 47.
    The weirdest thing is that i couldn’t ping any dns’s or i couldn’t ping my own ip on the internet (using another internet connection) but i could ping my own ip, and if i moved my address 1 number forward or backward i could ping them as well…
    it was as if my internet connectiong was accepted into a limbo pit of some sort, the worst part is that vodafone doesn’t provide tech support for anything that doesn’t use their own stuff…
    So my second option was to use my router and connect it to the pfsense wan port, and have a router on top of a router… and use the second’s dhcp service…
    Not good
    end.

    Anyway your method is interesting, and it would solve me a lot of problems.
    is there a way i could reach my pxe boot from the exterior?


  • Moderator

    pfsense is a good option, but not the only one.

    If you are using a soho (home router) that doesn’t support dhcp booting options, you can use / install a service on the FOG server called dnsmasq. This is a dhcp proxy service that will supply the boot information only to the pxe booting client.

    Just install dnsmasq from your linux distro’s repository. Then edit / create a file called ltsp.conf in the /etc/dnsmasq.d directory. In that ltsp.conf file put in the following :

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,<fog_server_IP>
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # inspect the vendor class string and match the text to set the tag
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    
    # Set the boot file name based on the matching tag from the vendor class (above)
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI,ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI64,ipxe.efi,,<fog_server_IP>
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
    
    dhcp-range=<fog_server_ip>,proxy
    

    Don’t forget to replace <fog_server_ip> in the above text with the IP address of your fog server. The tag appears many times.

    If your distro has a config file in that directory, remove it and only place one config file (ltsp.conf) in that directory path.

    One other point to check, make sure the version of dnsmasq installed is 2.76 or later. You can find out by using the following command: dnsmasq -v


Log in to reply
 

380
Online

6.1k
Users

13.5k
Topics

127.2k
Posts