UEFI, Dell Workstation Tower, FlexBay PCIe NVMe, Windows 10, FOG cannot detect PCIe NVME SSD



  • Hello,

    This post is similar to these 2 posts:

    https://forums.fogproject.org/topic/12318/dell-precision-tower-5820-flexbay-minisas-pcie-nvme-ssd-not-recognized/115

    https://forums.fogproject.org/topic/11156/cannot-find-disk-on-system-nvme-raid-mode-intel-rst/6

    The company I work for recently purchased 5 Dell Precision 5820 desktop computers. We got PCIe NVMe SSDs for these machines. They are installed in the same type of FlexBay system that’s in the first link I have listed above. I have tried troubleshooting steps in both of the links above, and am still coming up short.

    I am able to boot on our network using the ipxe.efi file. I have RAID turned off and AHCI enabled. I have secure boot turned off. The first picture is the error i get when trying to deploy my Windows 10 image to the computer. The second picture is the output of the command “lspci -nn” in the fog debug console.

    The picture in the second link above where the guy types “blkid” and gets the “/dev/ram0” output: I get the same exact thing.

    Any help would be appreciated. I won’t be back in the office until this Monday at 8 a.m. CST (I am located in Chicago).

    Thank You!
    0_1541805458062_fog_error_1.jpeg

    0_1541805542899_fog_lspci-nn.jpeg


  • Developer

    @afriedman said in UEFI, Dell Workstation Tower, FlexBay PCIe NVMe, Windows 10, FOG cannot detect PCIe NVME SSD:

    Is there any way I can incorporate these .cat, .inf, .sys, and .oem files into the FOG deployment process, since Windows Setup can use them to see the SSD?

    Those drivers won’t help you with FOG. They are from a completely different world and won’t work on Linux / FOG.



  • Major Update:

    • I made a bootable Windows 10 USB to see if that could find the SSD. It didn’t, which wasn’t surprising. After on the phone with Dell ProSupport for over an hour, their tier 2 engineers gave me this link to download some files from: https://downloads.dell.com/FOLDER04699307M/1/Intel-Rapid-Storage-Technology-enterprise-F6-Driver_TV5DJ_WIN_5.3.1.1019_A03.EXE

    • I ran the EXE and extracted the contents. I put the folder “RSTe_f6_iaStorE_win8_64” on the root of my Windows 10 bootable flash drive, booted off of it, used the “Browse” option when it couldn’t find a storage drive, pointed it to that folder, and it actually found the SSD! I successfully clean installed Windows 10 from a bootable USB onto this SSD that’s in the FlexBay.

    • After clean installing Windows 10, I tried booting off the network and deploying an image to the machine, since I did all this with the BIOS setting on AHCI. Unfortunately, this did not let FOG detect the SSD. BUT, I did find drivers for this FlexBay system.

    Is there any way I can incorporate these .cat, .inf, .sys, and .oem files into the FOG deployment process, since Windows Setup can use them to see the SSD?



  • Few things:

    1. I was actually finally able to image a different new machine earlier = Precision 7730 (laptop); not a 5820 desktop tower. That laptop is imaged and is working fine, other than having to manually install drivers.

    2. Upgraded to FOG 1.5.4 and upgraded the kernel to “Kernel - 4.16.6 TomElliott 64”. Just tried imaging the 5820 desktop tower and I’m still getting the error "Cannot find disk on system (getHardDisk) like in the first picture in my original post above. I tried following the short guide I mentioned earlier with this tower, and it hasn’t showed any progress. I also have 4 other desktop towers that are identical to this one, and I tried this on one of the other towers too, so I don’t think the first one is a lemon.

    Any ideas on what to try next?



  • Thanks Sebastian. I recreated the image and made sure “Windows 10” was chosen for OS type. I’m currently upgrading my FOG version and Kernel version. Hopefully that will fix some of these issues.


  • Developer

    @afriedman said in UEFI, Dell Workstation Tower, FlexBay PCIe NVMe, Windows 10, FOG cannot detect PCIe NVME SSD:

    Checking Operating System … Windows XP

    Although it might sound like FOG is trying to guess the OS you have I can assure you it’s not! That output is simply based on the OS you have set in your image. So check your image definition and change that if you don’t want it to be Win XP.



  • Its booting off of the ipxe.efi file and goes through the steps:

    • Running post init scripts … Done
      FOG Logo
      Version 1.5.0
      Verifying network interface configuration … Done
      Checking Operating System … Windows XP

    It has done that the last 3 times I’ve deployed an image to the machine. But of course, whenever I try to extensively troubleshoot something, it finally decides to work = I just tried imaging the computer again, and now it says the Operating System is Windows 10. After that deployment finished, i saw it preparing the drivers, but when i logged into the local profile in Windows, the drivers still aren’t installed, like what happens with my Windows 7 image.

    Regardless, as I worded in my previous reply to George, is there an optimal way to deploy drivers to my computers after the image deployment process that’s simple & straight forward?

    Also, attached are 3 files in txt form (fog.drivers, fog.hostinfo, fog.postdownload) that run after my FOG images deploy. 0_1542043375138_fog.drivers.txt 0_1542043378294_fog.hostinfo.txt 0_1542043383550_fog.postdownload.txt

    You may see in the fog.postdownload.txt file that it mentions the “fog.ad” file, but I don’t use that anymore; I use the FOG Client for joining machines to my domain.


  • Developer

    @afriedman said:

    For some reason, FOG is detecting the OS as Windows XP.

    Where do see FOG detecting you system as WinXP?



  • Thanks for that George. I’m primarily focused on Windows at this point now, but thanks for the Fedora information.

    About 15 minute ago, I was able to follow this short guide that allowed FOG to see the PCIe NVMe SSD: http://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/

    Unfortunately, I still have 1 last problem: I have a script called “fog.drivers”, located in the “postdownloadscripts” folder on my FOG server, that sees which OS type the deployed image is and pushes drivers to the computer getting deployed, after the image is deployed. These are CAB drivers I get from Dell. For some reason, FOG is detecting the OS as Windows XP. It seems to be happening on this brand new hardware. The older hardware I have, older OptiPlex machines, have 0 issues with this. My Windows 7 image doesn’t have a problem with this either.

    Should I update the kernel version? Also, is there a better way to deploy drivers than what I’m currently doing?


  • Moderator

    @afriedman So far we haven’t had good luck with these systems (as you might have saw from the other thread). Something changed in the linux kernel between 4.13.9 and 4.15.2 to cause these disks to become invisible (probably because the code to activate them moved to a kernel driver the developers don’t load by default). Later commercial linux distros seems to work (like FC28 and FC29), which use more up to date linux kernels.

    Without having one of the systems in the developers hands its very difficult to debug and find the right (missing) kernel driver or required firmware (just thought about that).

    Either way you should update to 1.5.4 or 1.5.5 (better choice) when its released because there has been many fixes since 1.5.0.



  • FOG Version = 1.5.0

    Kernel Version = I ran the “uname -r” command and it came back with this: 4.4.0-116-generic

    I’m using Ubuntu Server 16.04.4 LTS 64 Bit

    This is the SSD that’s in the machine: https://www.intel.com/content/www/us/en/products/memory-storage/solid-state-drives/professional-ssds/pro-7600p-series/pro-7600p-series-256gb-m-2-80mm-3d2.html


  • Developer

    @afriedman Which version of FOG do you use? As well please check the kernel versions and post here.


 

555
Online

5.4k
Users

12.6k
Topics

118.8k
Posts