"1.0E.19": invalid integer value" error



  • 0_1541166943902_2018-11-02_9-55-19.png

    Started getting this error. Not sure what to do now to resolve. My build is Ubuntu Server LTS 16.04 and fog server 1.5.4. Imaged some HP Elitebook 840 G3’s fine and then created an image for a Dell Optiplex 7060 and tried booting up to the fog server to upload this image and got this error on both the Dell and now HP’s as well… Everything was working fine with the HPs until now. Any help is appreciated.



  • @Sebastian-Roth

    Ok. I will change those values to 0 on Monday and let you know if it boots up. Appreciate he help!!!


  • Developer

    @mlawhun0114 Ok, well go check your settings in the web UI: FOG Configuration -> FOG Settings -> FOG Boot Settings -> PXE MENU TIMEOUT

    Probably someone wanted to have an infinite menu timeout and did set it to a very high value. Somehow FOG stumbles over the value of 9999999 and prints 1.0E+19 instead when generating the menu code.

    Edit: I just tested and couldn’t replicate the same issue on my machine. When I set 9999999 through the web UI, I see that value in the database but get a proper --timeout 9999999000 as output in the boot menu.
    Turns out I can go as far as 999999999999999 and still get a proper timeout value printed. Adding another figure I hit the same wall. I guess the difference is because of 32/64bit mysql client libraries.

    If you really want infinite/no timeout, just set the value to zero!



  • @Sebastian-Roth

    Ok I ran your commands, and here are the results I get.

    mysql> SELECT * FROM globalSettings WHERE settingKey LIKE '%PXE_MENU%';
    +-----------+----------------------+-----------------------------------------------------------------------------+------------------+-------------------+
    | settingID | settingKey           | settingDesc                                                                 | settingValue     | settingCategory   |
    +-----------+----------------------+-----------------------------------------------------------------------------+------------------+-------------------+
    |        69 | FOG_PXE_MENU_TIMEOUT | This setting defines the default value for the pxe menu timeout.            | 9999999          | FOG Boot Settings |
    |        73 | FOG_PXE_MENU_HIDDEN  | This setting defines if you would like the FOG pxe menu hidden or displayed | 0                | FOG Boot Settings |
    +-----------+----------------------+-----------------------------------------------------------------------------+------------------+-------------------+
    2 rows in set (0.00 sec)
    


  • This post is deleted!

  • Developer

    @mlawhun0114 Seems like something strange in the database. Please take a look at the settings on the command line:

    shell> mysql -u root -D fog -p
    Password:
    ...
    mysql> SELECT * FROM globalSettings WHERE settingKey LIKE '%PXE_MENU%';
    ...
    mysql> exit
    


  • #!ipxe
    set fog-ip 10.0.4.81
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    goto get_console
    :console_set
    colour --rgb 0x00567a 1 ||
    colour --rgb 0x00567a 2 ||
    colour --rgb 0x00567a 4 ||
    cpair --foreground 7 --background 2 2 ||
    goto MENU
    :alt_console
    cpair --background 0 1 ||
    cpair --background 1 2 ||
    goto MENU
    :get_console
    console --picture http://10.0.4.81/fog/service/ipxe/bg.png --left 100 --right 80 && goto console_set || goto alt_console
    :MENU
    menu
    colour --rgb 0x00567a 0 ||
    cpair --foreground 1 1 ||
    cpair --foreground 0 3 ||
    cpair --foreground 4 4 ||
    item --gap Host is registered as 98e7f4f6f277!
    item --gap -- -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.keyreg Update Product Key
    item fog.deployimage Deploy Image
    item fog.multijoin Join Multicast Session
    item fog.quickdel Quick Host Deletion
    item fog.sysinfo Client System Information (Compatibility)
    choose --default fog.local --timeout 1.0E+19 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    :fog.memtest
    kernel memdisk initrd=memtest.bin iso raw
    initrd memtest.bin
    boot || goto MENU
    :fog.keyreg
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param keyreg 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    param sysuuid ${uuid}
    :fog.deployimage
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    param sysuuid ${uuid}
    :fog.multijoin
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param sessionJoin 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    param sysuuid ${uuid}
    :fog.quickdel
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param delhost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    param sysuuid ${uuid}
    :fog.sysinfo
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=http://10.0.4.81/fog/ consoleblank=0 rootfstype=ext4 storage=10.0.4.81:/images/ storageip=10.0.4.81 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    :bootme
    chain -ar http://10.0.4.81/fog/service/ipxe/boot.php##params ||
    goto MENU
    autoboot
    

  • Developer

    @mlawhun0114 You need to open that URL in your local browser and copy/paste the output you see in the window here.




  • Developer

    @mlawhun0114 Looks like this could be some kind of number overflow. I have not seen this before so haven’t got a quick answer for you.

    Please open the following URL in your browser and post the full output here - put in FOG server IP instead of x.x.x.x and one of the client’s MAC address for aa:bb:cc:dd:ee:ff: http://x.x.x.x/fog/service/ipxe/boot.php?mac=aa:bb:cc:dd:ee:ff


Log in to reply
 

432
Online

6.2k
Users

13.6k
Topics

128.1k
Posts