Keep getting "Could not find partitions" error when capturing image.



  • I keep getting the error shown in the attached graphic whenever I try to capture an image. I can deploy an image from the same FOG server without issue. Everything I have found on the FOG Technical Help as well as through Google either is not fixed or just says something like “Thanks! That works great!” but does not say what the actual fix was. The system I am trying to create the image from boots to the OS (CentOS) without issue as well. I am pulling out what little hair I have left trying to figure this out.

    0_1539905630156_Fog error.png


  • Moderator

    Any reason why you’re using raw image over something like resizable? Is there something special about the partitions or disk layout?

    It also wouldn’t hurt to update FOG to the latest :)


  • Developer

    @enswafford said:

    All of the settings listed worked before on other images and on this same host.

    So I would wonder what changed since then!?

    Please schedule a debug upload task on this machine and when you get to the shell run the following commands:

    lsblk -dpn
    fdisk -l
    

    Please take a picture and post here.



  • @Sebastian-Roth
    I am using FOG 1.5.2.
    On the system I a m trying to image from, the system boots to the OS with no problem it is a 960 GB SATA SSD. I have created images in the past on this same FOG server with no problem. A few months ago, I deployed an image to this host without issue. All of the settings listed worked before on other images and on this same host. I have attached a screen capture of the image settings, as well as the host settings.0_1540330307586_System Settings.png 0_1540330077878_Image Settings.png


  • Developer

    @enswafford Ass well we need to know the FOG version you are using. From the picture I see I get the impression you are using an kind of old version.

    Two things that jump at me in the picture are:

    • “fog.upload Args passed:” -> Just empty, so we cannot find your disk I suppose.
    • “Reading Partition Tables … Failed” -> probably because we cannot find the disk at all.

  • Moderator

    Can you give us a bit more information about

    a) the image settings
    b) the host system you’re trying to capture (RAID? LVM? GPT? What kind of storage does it use? etc)


Log in to reply
 

485
Online

5.9k
Users

13.3k
Topics

125.0k
Posts