Unable to pxe boot Parted Magic Parted_Magic_2018.04.30.iso



  • Hi,

    I did follow the instruction available in the FOG Wiki for Parted Magic :

    https://wiki.fogproject.org/wiki/index.php/Include_any_ISO_in_the_FOG_Bootmenu

    (Followed the instructions to extract the SQFS too)

    I did the following configuration and it seems to boot ok :

    kernel http://${fog-ip}/fog/ISO/Utilities/PARTED_MAGIC/pmagic/bzImage64
    initrd http://${fog-ip}/fog/ISO/Utilities/PARTED_MAGIC/pmagic/initrd.img
    initrd http://${fog-ip}/fog/ISO/Utilities/PARTED_MAGIC/pmagic/files.cgz
    initrd http://${fog-ip}/fog/ISO/Utilities/PARTED_MAGIC/pmagic/fu.img
    initrd http://${fog-ip}/fog/ISO/Utilities/PARTED_MAGIC/pmagic/m64.img
    imgargs bzImage64 boot=live ip=dhcp edd=on noapic load_ramdisk=1 prompt_ramdisk=0 rw vga=normal sleep=0 loglevel=0 keymap=us splash quiet - || read void
    boot || read void

    But… I keep receiving the following message after a kernel panic :

    0_1539715137427_PartedMagic-2018-03-30-Kernel Panic.png

    What step are missing to have a successfull boot?

    Regards,

    Steve



  • @george1421

    Reading the Parted Magic Frugal install instruction did get me some valuable information :

    https://partedmagic.com/frugal-install/

    Simply put, the boot process for Parted Magic will seek the Squashfs in removable devices, which do not exist in a “sanboot” :

    root=/dev/sdXX

    Starting with PartedMagic 6.2 the search for the pmagic-.sqfs file will begin with the removable devices, unless a device/partition (root=/dev/sdXX), label (label=XXXXXXXX) or partial uuid (uuid=XXXXXX) is stated. Without such a kernel boot parameter a 10 seconds delay will occur.*

    Furthermore, the boot must be set to “boot=/boot” :

    directory=/boot

    Previous versions of this document said to copy the “pmagic” folder to ”/”. This carried the risk of a subsequent run of PartedMagic from a CD or a USB stick to find the pmagic-.sqfs file on the disk instead of the on the media – something you would not want in the majority of cases.
    Starting with PartedMagic 6.2 the risk is inverted: a subsequent run of PartedMagic from the disk might find the pmagic-.sqfs file on the media.
    The solution in both cases is to “hide” the “pmagic” folder on the disk in e.g. the ”/boot” folder.


  • Moderator

    @Steve_BBA You did find one of the limitations with memdisk, in that the iso image has to fit in the 32 bit address space and have enough space left over to run what ever kernels is on the iso image. The other limitation you will have with memdisk is that its bios mode only. There isn’t an equivalent boot environment for uefi AFAIK.

    But well done getting it worked out.

    From your initial error message was that it can’t find the initrd to boot from. This is me just guessing but I don’t see a kernel parameter in the imgargs that points to your initrd image. Also be aware that the format you used in your initial post isn’t sufficient for uefi booting. You need to use the -n <file_name> option for each line.

    ref: https://forums.fogproject.org/topic/10944/using-fog-to-pxe-boot-into-your-favorite-installer-images/10



  • Ok, I had it my way but the ISO required some mods.

    Using instead in my FOG boot menu :

    • kernel http://${fog-ip}/fog/ISO/memdisk iso raw || goto failed
    • initrd http://${fog-ip}/fog/ISO/Utilities/Parted_Magic_2018.04.30_slim.iso || goto failed
    • boot || goto failed

    I had to downscale ISO so it would fit in a memdisk ISO allocation, which limited to around 608 MB… So I kept the 64 bits images and kernels. All 32 bits stuff was deleted. Runs fine with this “slim” Parted Magic, 64 bits only.

    I’ve used ISO Master program in a Debian 9 machine to trim down the ISO content from 624MB down to 582MB.

    Steve


 

570
Online

5.4k
Users

12.6k
Topics

118.8k
Posts