Trouble with Debian 9.5 pxe install with NFS. Need some help.

  • I’ve followed this to get a pxe debian 9.5 installer working. The trouble is that when I boot in to the installer it always asks me to select a mirror. I do not want to select a mirror. I want it to load the files from the local NFS share, because this is on a private network with no internet access.

    I’ve verified that I am able to mount the NFS share from any address on my network. Here is the menu option -
    kernel http://${fog-ip}/bootimgs/debian/oldIso/install.amd/linux
    initrd http://${fog-ip}/bootimgs/debian/oldIso/install.amd/initrd.gz
    imgargs linux initrd=initrd.gz root=/dev/nfs netboot=nfs nfsroot=${fog-ip}:/var/www/html/bootimgs/debian/oldIso/ ip=dhcp rw
    boot || goto MENU

    It seems like the ‘imagargs’ isn’t doing anything but I’m not sure how to test it properly. In my /var/log/messages I never see an attempted NFS mount.

  • Thanks Sebastian. I was able to get my local debian mirror setup and working. I had to pass a bunch of kernel options over to get things started. Here is my boot option.

    kernel http://${fog-ip}/bootimgs/debian/oldIso/install.amd/linux preseed/url= ksdevice=bootif netcfg/link_wait_timeout=10 netcfg/dhcp_timeout=60 netcfg/choose_interface=auto auto-install/enable=true priority=critical hostname=unassigned-hostname domain=unassigned-domain console-setup/layoutcode=us console-setup/ask_detect=false locale=en_US ipv6.disable=1
    initrd http://${fog-ip}/bootimgs/debian/oldIso/install.amd/initrd.gz
    boot || goto MENU

    Also here is a good tutorial for having your own Debian repository mirror if anyone else stumbles upon this topic

  • Senior Developer

    @coreyman Here you find information on how to specify the preseed file:

    You should be able to add this to imgargs.

    I don’t think we are the right people to help you with all this. Don’t get me wrong, I do not want you to turn away from the FOG forums! I just think there are other people and forums out there able to give much better answers to your questions on this specific topic.

  • @Sebastian-Roth I’ve never had to create a local package mirror before to load OS installation files so I can install the operating system, but I’ll do it this time. All the installation files are included on the cd/dvd ./shrug

    I need to add this as a kernel argument on boot to use a preseed file. Can I do that with imgargs?

  • Senior Developer

    @coreyman The nfsroot kernel option is explained here:

    This has nothing to do with packages! Sure it can mean that on the root filesystem mounted via NFS there might be packages but this is not what nfsroot is being intended for.

    If you want auto selected mirror you will probably need to look into Preseed - no matter where your package files are located HTTP or NFS (within the nfsroot).

  • The NFS logs aren’t saying that anything has initiated a connection attempt when I load Debian over PXE. I’m using the debian full dvd iso, that should have the packages locally already. I’ve used fog before and I was pretty sure that was why you would mount an NFS share (to load the packages). The kernel boots without the NFS share. If this isn’t what the NFS share is for in the example can you please enlighten me?


  • Senior Developer

    @coreyman Please post a picture of the message when it tells you to “select a mirror”. I am guessing that these are two different things. One is the installer system located on the NAS being loaded on bootup. I guess this is working properly because it would fail to boot up otherwise. The mirror selection within the installer system is something different. I don’t think this can be influenced using kernel/imgargs parameters.

    You need to read up on how to impose a local package mirror (usually HTTP not NFS) to the installer! I am sure you will find many posts on this topic on the web.