Fog PXE Boot issues in VMware

  • I have open a ticket with VMware and they say it is not there issue. I can not boot from VMware workstation pro. I have bios set to UEFI. Not sure why. I am on windows 10. I have tried bridged and nat. I am unable to get it to pxe boot. It stops at the screen and says start pxe over ip4. I am not sure why. I know I can reboot the computer and then to the setup screen and I can select uefi network boot ip and it works fine. I just do not know why UEFI is not working in VMware workstation. Has anyone seen this. I can push an image out all day using fog. I just can not upload one from vmworkstation. Is there a bootable fog image iso that I can try ?

  • @george1421 I have finally got it resolved. I went back to vm workstation support and they updated a file in their install . Then it magically started to work

    They think the install file was corrupt on their side

    Too odd.

    Thanks everyone helping

    I was running the latest build on version 15

  • i have finally figured out how to get vm workstation working with no problems. My computer is plugged into real network at the time. I have to plug into the isolated network. When it pulls an IP address I then go and disable the adapter and enable it again. it then gets the ip address again. I then run ipconfig /flushdns.

    After i do that and only then will i start VM workstation. i will go to the vm and go back to my snapshot. before i open it i always make sure the settings are showing bridged. I then power on the vm to the saved stated and run a ipconfig to make sure the computer and vm have actual same IPs in the subnet. Then run a flushdns on the vm. Then i sysprep and then boot to firmware on the vm. Then i pick network boot.

    This has worked 7 times with no issues. I am sure i could cut out some steps but it is real easy for me to do all of it real quick. I only check to make sure it is bridged mode once.

    Once i started to do this vm workstation work everytime and even on VM reboots.

    I hope this helps someone else out.

    Oh and i disable wireless first if you are using that.

  • @george1421 @Sebastian-Roth yes the only issues is vm workstation and it is in bridge mode. I just got it to work once so far. It is uploading the image and nothing changed at all. Just on that restart I did it just via network IP 4. I booted to firmware and then picked network card.

    This drives me nuts .

  • Developer

    @mmoore5553 As mentioned several times, bridged network mode in VMware will be the only proper option for you here. Possibly best if you take a picture of the settings dialog and post here.

  • Moderator

    @mmoore5553 Understand I’m still trying to get the picture of what is not working here; so physical machines get their IP address no problem when plugged into the unmanaged switch. The only issue is with the virtual machine running under vmware workstation?

  • @george1421 yes the fog server should be handling dns and dhcp. The computer gets an ip address each time and dns. I have a spare fog server i am booting up now but it had the same issues before .

  • Moderator

    @mmoore5553 So you have just a simple network setup, only a vm host server, a network switch and a fog server. What is your dhcp server for this network? Do you have the fog server issuing dhcp addresses to the target computers?

  • @george1421 my setup is simple. I have a computer that is connected to netgear switch. It is an unmanaged switch. It then connects to the fog server . That is the only computers on this switch. We do not have it on a network at all but this isolated network. I have never ran into this issue. Before i brought it here it was pushing out images all day when you pulled the image- booting a computer up and then pulling the image from the fog server. One thing I did notice on the fog server that it is not putting a gateway in IPconfig. Not sure why. I am going to pull out my old laptop fog server . Do i need to get the special file off of it ? or are those files the same from server to server. That fog server is 1.0.5

  • Moderator

    @mmoore5553 OK so iPXE is running. The error message says that its not getting an IP address on the interface identified by the mac address.

    So, I have to ask the question(s)

    1. For this VM, is it connected by a bridged interface to the physical network adapter?
    2. For the network where this VM is connected; what device is your dhcp server?
    3. Is your FOG server on the same subnet as this VM?
    4. What do you have configured for dhcp option 66 and 67?

    My intuition is telling me you have an infrastructure issue, not necessarily a fog issue. You say that physical computers pxe boot without issue. I’m almost thinking its on the vm networking side.

    If the fog server is on the same vlan as the pxe booting VM we might be able to use the fog server to find out what is being sent by the client computer.

  • @george1421 i made a usb boot disk but run into errors there too. This is a pain. I do not know how i am going to get my golden image updated. Here is the error i get0_1539024340497_unable to get dhcp fog.png

    if i just boot the usb drive and computer. I get connected and IP address but then it says it can not find an image when i select it. UGH .

  • Moderator

  • @george1421 i am lazy. I can paypal you some money if you make the iso for me LOL . Just let me know how much.

  • Moderator

    @mmoore5553 PXE booting from a cold boot worked more often than not. But I agree its pretty annoying.

    I have not tried this but if you make a uefi iso image you may be able to boot into ipxe pretty reliably. As I posted before you will need ipxe.efi from the fog server and then just manually create the uefi disk structure and rename the ipxe.efi to boot64.efi (you will need to confirm the actual uefi boot file name) then create your iso image. Configure your vm to boot from the uefi disk and it should launch ipxe and the fog menu. That will bypass the entire pxe part of the process.

  • @mmoore5553 @george1421 I can confirm that it is hit or miss. It is very annoying. I would put the image on exsi but we have to have it on an isolated network. I just find it odd since this just started happening and i never had it before. I was using version 12 before but then it started doing the issue. Now I am back to not getting it to boot.

    Something i really hate being the guy that maintains the golden image.

  • @george1421 I have finally got it resolved. I went back to vm workstation support and they updated a file in their install . Then it magically started to work

    They think the install file was corrupt on their side

    Too odd.

    Thanks everyone helping

    I was running the latest build on version 15

  • Moderator

    @george1421 After trying this, that, and the other thing… I’ve come to the conclusion that pxe booting a vmware 11 client in uefi mode is problematic at best. Its totally random when it wants to network boot or not. It WILL boot consistently in bios mode warm or cold boot.

    I imagine that one could create a uefi iso image and boot it that way into fog if you needed a uefi base image. It should be that hard to do. You will just need ipxe.efi from the /tftpboot directory on the FOG server and a few minutes of time.

  • Moderator

    @george1421 I can pxe boot into the fog iPXE menu using VMWare workstation 11 with the target computer in EFI mode from a cold boot only. When I try a warm boot the vm gets stuck like Virtual box does. Cold boot the vm and it boots into iPXE. This is an issue with the hypervisor not FOG. When I develop my golden images, I use ESXi and there is never an issue with network booting cold boot or not.


    Edit: Well maybe it only worked the very first time I setup the VM. Subsequent tries gives me a timeout error and throws me to the EFI boot manager.

  • @Tom-Elliott if I reboot the computer it will find fog fine. No issues there at all. Just when I am in vmworkstation pro. it is VM software like virtualbox.

  • Moderator

    @mmoore5553 What version of vmware workstation are you using? I’m running VM Workstation v11 on my system.

  • Senior Developer

    @mmoore5553 That’s what makes me think networking is the problem. As you’re saying this is happening on a VMWare Workstation, this make me think the installation is not bridging to the “real” network adapter that is connected to the managed switch.

    I’d almost guess that the machine you’re running VMWare Workstation from probably can’t even boot into fog?

    There is means to do USB booting, but I don’t know how to translate that to VMWare Workstation, it’s not even something I fully support (though I’m not afraid to lead a horse where it needs to go.)

    This is made by @george1421:

Log in to reply