Time Zone Error on Kernel Update

  • I have a new FoG setup. It is on a HyperV Generation 2 VM. Everything seems to have gone ok but we can’t seem to clone Windows 10 machines. We received errors about the partitions. I researched this and found I should try some new kernel images. When trying to update the kernel, I received the following error:

    Type: 2, File: /var/www/html/fog/lib/fog/fogftp.class.php, Line: 463, Message: ftp_login(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone., Host: x.x.x.x, Username: xxxxxxx

    I have made sure FOG and Centos 7.5 are both set to UTC. I have also tried EDT but that hasn’t changed this error. Is there anyone out there that has seen this?

  • It works now! Thank you for all your help!

  • Developer

    @geekygary To quote George from just a day or two ago:

    The unclean file system message is because windows was not shutdown properly before you attempted to capture it. Use either sysprep to power off the device or run the command shutdown -s -t 0 command to properly power off the device. The simple Startbutton->Shutdown will not properly power off the device.

  • I decided to wipe the files and download them again. This time it worked. I ran the fixparts and then I restarted to capture the image. It booted up to capture it but says that the NTFS partition is unsafe.

  • There were no errors after the wget commands. I am running Fog 1.5.4 with bzImage 4.18.11 and bzimage32 4.18.11

  • Developer

    @geekygary I just downloaded the latest init.xz as posted to test myself and I don’t get that issue. You sure the download succeeded? Which kernel version are you running right now?

  • Here is the error I get after following those directions:

  • Senior Developer

    @Sebastian-Roth that’s what I was thinking just wanted full understanding.

  • Developer

    @Tom-Elliott I think this has been an issue when FOG has been installed about two or three month ago. Please try updating to the latest inits and I am fairly sure you shouldn’t see the “cammand not found” issue anymore.

    sudo -i
    cd /var/www/fog/service/ipxe
    mv init.xz init.xz.orig
    wget -O init.xz https://fogproject.org/inits/init.xz
    mv init_32.xz init_32.xz
    wget -O init_32.x https://fogproject.org/inits/init_32.xz

    Now try again.

  • It says fix parts is missing.0_1539099584706_IMG_7837.jpg

  • Developer

    @geekygary Schedule another job but this time make sure you tick the checkbox for debug! Boot up the client and it will bring you to a command shell. Now start the job by issuing the command fog and follow through by pressing enter as being asked to. When you hit the error you should be back to the command shell. Now run fixparts /dev/sda (put in the correct disk you have in the client) and see what the error is. We run this command using an automated answering file to fix partition layouts but in some cases this can fail. Take a picture of the error on screen and post here.

  • @Tom-Elliott Could not fix partition layout (runFixParts)
    No matter what I do, I just keep getting that on trying to clone Windows 10. Windows 7 works just fine.

  • Senior Developer

    @geekygary what runFixparts alert?

  • I am circling back to what prompted me to do the kernel update in the first place. When trying to clone Windows 10, I was getting a Could not fix partition layout (runFixParts) error. I updated the kernels to the ones released on October 2, 2018 and I am still getting the runFixParts alert.

  • You rock! It was .fogsettings file that had the old password. That timezone error just threw me for a loop.

  • Developer

    @geekygary Ignore that timezone warning message for now. Fairly sure there is something wrong with your FTP login on the FOG server. Check out this wiki site and see if you can fix it: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP

Log in to reply