"Operation not supported" tftpboot failing - please help



  • Hi there, sorry if this exact thing has been discussed before but I am stumped.

    I have a brand new installation of FOG Server v1.5.4. It is running on a VM with Centos7 as the OS.
    Nothing else is on that machine.

    I changed the DHCP server option 66 and 67 on our Windows DHCP server.
    66 is the IP address of the FOG Server.
    67 is “undionly.kpxe”

    When I try to boot a machine to the FOG Server I can see it taking its DHCP address and pointing to “Next Server: <fog ip>” but then I get:

    tftp://<address of fog server>/undionly.kpxe… Operation not supported. (http://ipxe.org/3c126003)

    I have tried using different machines both physical and virtual.
    Some give me that error and others just don’t boot.

    I have reinstalled fog and checked things like the firewall etc.
    I have also tried using other pxe files like default.pxe and pxelinux.0
    Same error.
    When I installed it I said “no” to DHCP and DNS and setting up a router for DHCP.
    Everything else was left default.

    Does anyone have any suggestions regarding this issue?
    I can provide more details if required.

    Thanks everyone!!


  • Developer

    @fogofwar said in "Operation not supported" tftpboot failing - please help:

    Only one problem now that we got past that I am getting this error about “No configuration method succeeded” but only on a VM. I will have to look at that next.

    This is only on reboot I am fairly sure! Shut down the VM completely, bring it up again and PXE boot will work nicely. This is a known bug in virtualbox.


  • Moderator

    @fogofwar After studying the picture a bit I see that it is an intel emulation network adapter.

    If that was a physical machine I would say its a spanning tree issue. But since that is virtual it can’t be a spanning tree issue ATM.

    Ah the mac address comes back to virtual box. Mmmmm…


  • Moderator

    @fogofwar what virtualization environment are you using? If its esxi, make sure the network adapter is intel based not vmxnet based.



  • Great thanks, I forgot about SELinux. It works on physical machines now. Thanks for reminding me about that.
    Only one problem now that we got past that I am getting this error about “No configuration method succeeded” but only on a VM. I will have to look at that next.



  • 0_1537986939776_tftp2.jpg


  • Moderator

    @fogofwar OK lets start with…

    1. Have you set selinux to Permissive?
    2. Have you disabled the Centos firewall?
    3. Have you installed the tftp client feature in windows and attempted to use tftp from a cmd window to download undionly.kpxe?
    4. On your target computers, did you remember to disable secure boot?


  • 0_1537983076682_tftp.jpg


 

507
Online

5.4k
Users

12.6k
Topics

118.7k
Posts