Printer Management with FOG



  • Hello,
    First some informations about my System:

    root@FOG:~# cat /proc/version
    Linux version 4.9.0-8-amd64 (debian-kernel@lists.debian.org) (gcc version .3.0 20170516 (Debian 6.3.0-18+deb9u1) ) #1 SMP Debian 4.9.110-3+deb9u4 (2018-08-21)

    root@FOG:~# cat /etc/issue
    Debian GNU/Linux 9 \n \l

    Fog Version: 1.5.4.8
    bzImage Version: 4.15.2
    bzImage32 Version: 4.15.2

    I want to run four TCP IP Printer in my local Network on Port 9100. The addresses are
    192.168.0.212:9100 HP Laser Jet 712
    192.168.0.213:9100 HP Laser Jet 712
    192.168.0.214:9100 HP510 Plotter
    192.168.0.215:9100 HP510 Plotter
    I’ve two rooms where I want to assign one Laser Jet and one plotter.
    The Print Management should be done by Fog.

    My problems:
    -) Printers:
    In both cases (Plotter and Laser Jet) the Network connection is named on the local PC as 9100; The port name.
    If I do the installation by hand Windows names it with the IP address.

    As the two connections have the same name “9100” I think the second one replaces the first one … So I can only assign one Printer.

    -) Changing the printer setup on FOG changes sometimes nothing. (e.g. the name of the inf file - the printer …) My solution was to deploy the computer again …

    -) Group management with Printers: If I update a group with the option “only Assigned Printers” the clients are not updated. The are still in the mode “No Printer Management”

    -) How to install a local pdf Printer, when I use the option: “Only Assigned Printers”


  • Developer

    @kratkale Ok, I finally got the time to get into fog-client development again. I am trying to answer your questions step by step.

    About port naming: The field Printer Port is what you see in the Windows printing dialog as “Port name”. So if you put in 9100 it will be named 9100 but if you put in an IP the port will be named exactly as you want it. On the other hand if you want to specify a different TCP port for printing you put in x.x.x.x:9111 in the Printer IP field. I will change the field labels in the FOG web UI to make this clear.

    Changing the printer setup on FOG changes sometimes nothing. (e.g. the name of the inf file - the printer …) My solution was to deploy the computer again …

    I am not exactly sure if I get what you mean. Let’s see… If you change any of the settings in the FOG web UI while the fog-client is running on the computer the changes won’t be sent out to the client immediately. This is something I hope to change in the future but that’s how it is right now. But if you change things and then reboot the client machine it should use the changed settings!

    -) Group management with Printers: If I update a group with the option “only Assigned Printers” the clients are not updated. The are still in the mode “No Printer Management”

    This is a known issue I just fixed a couple of days ago. It will be in the next release!

    -) How to install a local pdf Printer, when I use the option: “Only Assigned Printers”

    Find out the settings used in the PDF printer (using the fog-client PrinterManagerHelper.exe or manually from the printer properties…) and set it up in FOG as well?! Should work I suppose.


  • Developer

    @kratkale Sorry for the long delay. I have had this topic on my list but I don’t seem to find the time to look into this. I don’t have a setup around at the moment and it would involve some effort to get it all up. Not sure when I will have enough time to do so.


 

561
Online

5.4k
Users

12.6k
Topics

118.9k
Posts