New FTP user



  • Hello,

    I would like to create a new FTP user ‘fogbackup’. Lock (jail) on own home directory.

    Install: Debian 9 + FOG Project 1.5.4

    I use:

    useradd fogbackup 
    passwd fogbackup
    usermod -d /home/fogbackup/ fogbackup
    service vsftp restart
    

    Use FTP client (WinSCP from MS Windows) and can’t login: authentication error.
    I read wiki: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP
    And as FOG user i can login successful.

    What am I doing wrong?

    Thanks for help



  • Solution my problem:

    1. tips of Sebastian Roth:
    mkdir /home/fogbackup/
    chown fogbackup:fogbackup /home/fogbackup/
    
    1. change config file /etc/vsftpd/vsftpd.conf
    vsftpd_log_file=/var/log/vsftpd.log
    log_ftp_protocol=YES
    allow_writeable_chroot=YES
    chroot_local_user=YES
    chroot_list_enable=YES
    chroot_list_file=/etc/vsftpd.chroot_list
    rsa_cert_file=/etc/ssl/private/vsftpd.pem
    rsa_private_key_file=/etc/ssl/private/vsftpd.pem
    ssl_enable=YES
    force_local_data_ssl=NO
    force_local_logins_ssl=NO
    

  • Developer

    @Valer said in New FTP user:

    useradd fogbackup

    That command does not create the user’s home directory (it does if you would have added the -m parameter). The following might do the trick:

    mkdir /home/fogbackup/
    chown fogbackup:fogbackup /home/fogbackup/
    

    If not then run tail -f /var/log/auth.log while trying to log in via FTP. This should give us some more information on why it does not allow the user to authenticate.


Log in to reply
 

475
Online

5.5k
Users

12.7k
Topics

120.2k
Posts