No configuration methods succeeded (I210 NIC) HP-Z240



  • So this is an HP workstation with an I210-T1 NIC I’m trying to image. It is UEFI, and I don’t make it to the FOG boot menu. Instead I get this:
    0_1536940790766_c9c4c532-02c1-4eba-a34c-00c0f386d787-image.png

    I added vendor codes to the DHCP / windows AD setup ages back, and all that is foggy. I can say that other UEFI boxes image ok.
    0_1536942849889_9c3eb6bb-3f78-4ee1-ade2-cabbbf57bcac-image.png
    0_1536943513626_d1958abb-432e-44a8-96fc-78ab62355bfb-image.png

    Any advice on how to get PXE up on this one?
    0_1536941076693_9abacd5d-5100-4cab-a465-ecdb3c3ab228-image.png


  • Moderator

    @geardog said in No configuration methods succeeded (I210 NIC):

    It turned out to be a bios/UEFI setting “option rom launch policies.” New to me. In my defense, this box’s bios is pretty massive and clumsy to navigate through, but works now!

    Well that is a new one for me too. You might want to post the model of HP computer this is just in case someone else has the same issue in the future. This issue does sound a bit unique to this hardware.



  • @george1421

    Tried disabling Spanning tree with no effect.

    It turned out to be a bios/UEFI setting “option rom launch policies.” New to me. In my defense, this box’s bios is pretty massive and clumsy to navigate through, but works now!
    I feel stupid, but my issue appears resolved! Thank you very much George. I might not have ever stumbled through those screens again if it weren’t for you.

    As an aside, the MAC address cloning is a little odd as fog find and tries to get an IP on the wrong NIC first, before it gives up and tries the next NIC.


  • Moderator

    @geardog My intuition is telling me spanning tree, but lets just confirm that the network adapter that iPXE is trying to init IS the network adapter where the ethernet cable is connected.



  • @george1421
    I hadn’t considered a MAC mismatch. This box has two NICs (one to control some equipment). They BOTH have the same MAC address… So maybe the box is trying to configure the first NIC that is only connected to a machine. Of course no IP will be given. Should I spoof a MAC for the “internet NIC” and enter taht in the host record? Will this method confuse FOG?


  • Moderator

    Well… it looks like you are booting into bios (legacy mode) so the dhcp server is sending the right file name as in undionly.kpxe to the target computer. It appears to download undionly.kpxe and boot it correctly. If you sent the wrong boot kernel like ipxe.efi to a bios mode computer you would not see the iPXE banner.
    What’s happening (assuming the mac address displayed is matching the real hardware nic you are trying to boot from) is that the iPXE kernel (undionly.kpxe) is not able to get an IP address from the network).

    iPXE sees the mac address so the network adapter is probably supported by iPXE. My next guess is that the network switch port that connects this pxe booting computer to the network has spanning tree enabled, but is not using one of the fast spanning tree protocol such as fast-STP, RSTP, MSTP, etc.

    A quick check to confirm it could be a spanning tree issue is to place a dumb (unmanaged) switch between the pxe booting computer and the building switch. Then pxe boot the target computer. See if you can get the FOG iPXE menu that way. If it works then you need to contact your network engineers and confirm the spanning tree settings on every switch port where you might want to pxe boot a computer. Understand this is not a iPXE, FOG, or computer hardware issue, this (if its spanning tree) an infrastructure issue and you would have the same results with any other network booting imaging tool.



  • Details on this NIC say it supports pre-boot, but also speaks of available option ROMs. I’m not familiar with much of what I find in this document. Clueless here.

    https://www.intel.com/content/dam/www/public/us/en/documents/faqs/ethernet-controller-i210-i211-faq.pdf

    I might just swap out the NIC, but I don’t honestly know if it will make a bit of difference.


 

543
Online

5.4k
Users

12.6k
Topics

118.8k
Posts