Can't see Images in menu after manually uploading.



  • Ok, For whatever reason we lost power this last weekend. Unsure why I would have an issue being on backup batteries, but showed up to a fog server in a sad state. No menu via web GUI, no menu booting to it over network.

    No big deal I figured, been wanting to upgrade anyway. So I rsynced images to a local drive on my windows box. Just blew the VM away, and figured I would just upload the images to the new server.

    I’m running Ubuntu Server 16.04.5 Server X64. Installed Fog V 1.5.4, again without issue.

    I mounted my Windows share and rsynced the images back into the image folder after uploading a image manually. Went home for the night as I have 1.8Tb in images.

    If it matters the server is a Dell R900 X4 hex core Xeon Processors, 32Gb memory running vSphere 6.5.
    Fog runs on a Dell DAS 1000 with 10 X 3Tb SATA drives in a RAID10. 2 Lun’s with 1 HS drive each.

    I didn’t change Anything on ESXi, or the drives RAID. Just simply backed up the images, blew the install away and started over.

    Now I see rsync had finished, and Fog Dashboard shows space used, however I can’t see the images when I boot to deploy.

    I tried creating new image, gave it the same name as the one in images… However it says no file or directory found when I try to deploy. Mind you I can only see the one image I manually added after the fact manually. I did not actually upload it.

    I’m trying to get it to see the images in the folder, and figured I didn’t bring the database and that screwed me ?

    So now that I see a Export / Import images ( I didn’t see this before ) I figure there is other magic I need to perform to get Fog to notice and use the images I uploaded manually?

    Any help would be great ! Thanks in advance !


  • Developer

    @Cire3 said in Can't see Images in menu after manually uploading.:

    The compression scale also must match huh ?

    Sorry, I didn’t mean the compression scale but the compression format…



  • @Sebastian-Roth Yea, I remember some of this from before. I did create the image name exact so it matches the directory Fog creates. I upload all my images as single disk resizable. I’m not even getting to the partclone window.

    I’ll double check once again. The compression scale also must match huh ? Now that I didn’t know. Hell, that may have changed by what mood I was in…lol And time ;)

    I’ll give it another look, I know it has to be something stupid I’m missing.

    Thanks for your time as always !


  • Developer

    @Cire3 Yeah next time backup the database as well. But I am sure we will bring you back up on track.

    There is not much magic to it, FOG just needs image definitions exactly matching the names of folder(s) in /images. So if you have /images/MyGreatImage create a new image definition called MyGreatImage that points to the mentioned directory by default. Note this is case sensitive, so mygreatimage won’t work. As well you need to get the image type right (re-sizeable image type or non-resizable single disk or multiple disks). Just try the different options if you still have the “no image files found” error when deploying.

    If it starts deploying but fails in the blue partclone window, it could be the image compression method is still set incorrectly. Play with those settings as well.


Log in to reply
 

570
Online

5.8k
Users

13.1k
Topics

123.2k
Posts