Active Directory Page | Keeps on Defaulting to the same value



  • Fog Version: 1.5.4
    bzImage Version: 4.18.3
    bzImage32 Version: 4.18.3
    Note: I had to update the init.xz and init_32.xz manually due to issues when I was capturing an image.
    I think my issue started after doing so, but I don’t believe there is a connection between these 2 files and the OU field, so it does not make sense.

    The issue with the Active Directory page:
    When I go to update the various fields in the page: Organizational Unit; Domain Username; Domain Password and I do save the updated settings (I get the confirmation box); if I leave the page and go back it keeps on re-default to the same settings. The settings, it keeps on re-defaulting are not the default settings that I have set under the Fog Configuration. It is doing this for all hosts and groups.
    I also have to mention that the settings it keeps on defaulting to for the Organizational Unit is: WUSD.US/Cradleboard/Computers/ThinPC/
    It does not make sense since it should at least look like this:
    OU=ThinPC,OU=Computers,OU=Cradleboard,DC=WUSD,DC=US
    This is affecting old and new registered hosts or groups.
    I exported the database but I am not a database person and I don’t even know where to start.

    In advance thank you for your support and response to this question.
    I have been using Fog since 2009. This has been a great product for my k-12 school district.


  • Developer

    @pdehombreux Sorry for leaving you alone for such a long time on your very first post. It’s been a very busy time and I just couldn’t get my head around your post when I first read it and so kept on putting off to look into this.

    I think we need to get into the logs to see what’s actually happening when you try to update the AD information. First check the apache error and php-fpm logs right after (or while) you update the client’s AD information. See my signature on where to find those.

    If that does not shed a light (I suppose it won’t) then I may ask you to enable mysql query logs. For that it’s probably best to turn off as many components as possible first. Shut down clients that have the FOG client installed and make sure you are the only person on the FOG web UI for that moment. Just trying to keep the logs to a minimum.

    See here on how to enable mysql query logging: https://www.pontikis.net/blog/how-and-when-to-enable-mysql-logs

    Before you enable it, get the web interface ready. Navigate to the right host, select AD settings and change OU and username for example. Then turn on logging, restart mysql, update the client settings and switch off mysql logging again. Upload the full log here (make sure it does not contain any sensitive data …)


 

517
Online

41.9k
Users

12.4k
Topics

116.7k
Posts