SOLVED FOG - Please Enter TFTP Server

  • Currently I have run into an issue where, after having my FOG server offline for a few days, everytime I go to PXE boot a machine, I get ‘Please enter TFTP’ server.
    My FOG server does not handle DHCP that is by our 3 other DHCP servers.
    If I have the FOG server off, the PXE menu does not appear on the computer, if it is on I get to ‘Please enter TFTP server’.
    FOG was fully working before the few days I had it offline, and I have doubled checked the Option 66, 67 on my DHCP servers. I’ve tried running a wireshark and don’t see any packets going to the FOG server which is why I am confused why when FOG is offline that iPXE never appears.
    I have also verified from a Windows machine with ‘tftp -i get undionly.kpxe’ and the Transfer is successful.
    If there are any questions I can answer them as needed.

  • @Sebastian-Roth So after taking your advice on the multiple DHCP servers, I went and checked for any possible Rogue DHCP servers using Wireshark, and I found a range that is not apart of our usual subnet, was offering and broadcasting DHCP. So the issue was rogue DHCP.

  • The only thing that we changed on the network while the FOG server was down was we disabled Spanning Tree on one of our 10G switches.

  • @Sebastian-Roth I set just one server to be DHCP and still got the same results when booting a machine.

  • Senior Developer

    @rets34 said in FOG - Please Enter TFTP Server:

    9165 pts/0 S+ 0:00 grep --color=auto -e dhcp -e dnsmasq

    That’s just the grep command seeing itself. So seems like there is no DHCP (proxy) server running at the moment.

    Please make sure the other three servers are all in sync! What kind of DHCP is that? Having more than one DHCP is highly likely to cause issues!

    • Yes we have 3 DHCP Servers, I will confirm tomorrow that they all have the same server options across the board.

    • Option 66 & 67 are the same on all of them

    • 9165 pts/0 S+ 0:00 grep --color=auto -e dhcp -e dnsmasq

    • Running Ubuntu 18.04 | Kernal 4.15.0-33-generic

  • Senior Developer

    @rets34 So do I get this right? You have three (?) DHCP servers serving the clients and you don’t want/need the FOG server to handle DHCP? First make sure those three DHCP servers are in sync and not offering different things to the clients.

    The message “Please enter TFTP’ server” can be a bit confusing as it can happen either when there is no option 66 given on subsequent DHCP requests by the iPXE binary OR if there is more than one DHCP server answering and the answers are different.

    So I guess after bringing your FOG server back online a DHCP service came up as well. Run ps ax | grep -e dhcp -e dnsmasq and post output here.

    Which OS are you running? debian/ubuntu/centos/fedora/…?