SOLVED capturing windows 10 images

  • Is there any documentation regarding windows 10 (build 1803)?
    And how to configure it so fog can capture its image and deploy an image (on the same pc or on a new pc).

    I’ve followed the tutorial on how to setup FOG on debian (using Oracle box with a host only adapter)

    Next to that I’ve setup a fresh windows 10 (build 1803) with the fog client
    Now this seems to work as it shows up in the FOG gui.

    However when I want to capture the image windows gets stuck in a reboot loop and the scheduled task seems to stay as it is in the FOG gui.

    The analysis:

    Running in Virtual box:
    Debian 9 The fog server:

    Adapter 1 (NAT for internet):

    Adapter 2 (Host only for the lab):

    The windows 10 machine (the machine I want to image with FOG):

    Now it appeared I ran into some issue’s while configuring the static IP adress using

    source /etc/network/interfaces.d/*
    # The loopback network interface
    auto lo
    iface lo inet loopback
    # The primary network interface
    allow-hotplug enp0s3
    iface enp0s3 inet static
    allow-hotplug enp0s8
    iface enp0s8 inet dhcp

    However this turned out to throw a [FAILED] Failed to start Raise network interface.
    during startup, so I got some issue’s getting both my adapters to work.
    Any of the work arounds I found broke the installation of FOG.

    So I’ve decided to re-install debian this time with the GUI and Gnome.
    As such I’m able to configure the network interface using the gui:
    I also made sure the mac is also selected for both interfaces, as it didn’t show up when running ip addr in the command line.

    The first adapter is just set to DHCP.
    My second adapter is static.

    The fog installation:

    note the router is the VBox adapter ip (
    If you want to check yours go to global tools > Host network manager > properties > adapter and check the IPv4 address

    Next I install the Fog client on the windows machine (using sysprep so I can set it up before any users are made).
    Note: make sure you remove the windows iso before you run the sysprep reboot.

    After this I finish off the installation of Windows 10 and setup a test user.
    Once you login the fog client shows up in the hidden menu on the task bar (so the installation went correct).

    At this point I got the error when rebooting windows and attemting a PXE boot.
    as it turns out this is a Exec format error

    To fix this run the following in the terminal:
    file /var/www/fog/service/ipxe/bzImage

    Note that the windows system still gives the same error if you do a restart.

    However a shutdown and startup from virtual box works
    Note, I made sure network boot was setup in the system settings

    It now allows me to approve the host.

    once that process is complete it will reboot again (you get the same error again so instead boot it over the harddrive)

    I now created an image, associated it with the host and scheduled a capture task:

    The fog client will pop up in asking for a restart this shows the same error if you let it run.
    So instead shutdown the system and start it up again.
    it is now able to capture the image:

  • @Sebastian-Roth
    Thank you
    Its working now, I’ve updated the post with my steps.

  • Senior Developer

    @red_john said in capturing windows 10 images:

    it still seems to give the same error when I reboot windows.

    I have seen this quite often, rebooting the client in virtualbox VM it fails on DHCP just as we see in the screenshots. I have no idea what’s wrong with virtualbox here. I simply shut it down and startup again by hand. Have not hat the time to find a proper solution or workaround for this.

    note that I don’t have the option to select “Perform Full Host Registration and Inventory.”

    As you see it says: “Host is registered as DESKTOP-SIKRLDH” - so FOG already knows this client and shows a different menu for this registered client. Either it was registered earlier or you manually added the client in the web UI by its MAC address?!

    From here on, go ahead and create a image definition in the web UI, set this image for this client, schedule a task for it and see if you can capture an image…

    I renamed and moved you topic - just so you don’t wonder. I mark this solved as you seem beyond those first hurdles. Please feel free to open new topics if you run into more issues.

  • @Sebastian-Roth
    Thanks, looks like I’m getting somewhere now.
    I’ve set the DHCP server on in the installation of FOG.
    Also turned off the DHCP on the Virtual box adapter (to avoid any conflicts).

    It now pickes up the server when I reboot Windows over lan.

    However I do seem to run into a new error.

    If I look it up on the iPXE page it seems to point to a DHCP error again.

    Following the instructions on the wiki page:


    it still seems to give the same error when I reboot windows.
    however when i shutdown the windows vm and boot it up I get to see the fog menu.
    I’ve now approved the host using this.
    yet when it reboots I get the same error message:

    I get the following options if I shutdown windows and start it up again:

    note that I don’t have the option to select “Perform Full Host Registration and Inventory.”

  • Senior Developer

    @red_john Did you answer yes when being asked if you would like to enable DHCP with your FOG installation. I’d advise you to do so for now. It’s way easier than setting it up yourself if you are not into PXE booting much yet.

    So, setting it up as you did with two adapters should be ok as long as you make sure to setup a static IP on the second interface before running the installer and to tell the FOG setup to use that one. As mentioned let FOG run the DHCP server within your host only network and you should be fine. VirtualBox DHCP server seems to be able to PXE boot clients but it’s difficult to setup I read. Don’t go there if you don’t need to. FOG will do this for you.

  • Done a fresh installation of the FOG server on Debian in Virtual box.

    this time with two adapters to ensure there all setup correctly from the get go:
    One NAT for internet
    so the installation can be done without errors. (without a internet connection this errors out)

    And one host only
    (intelchip set with a DHCP server turned on)

    My Windows VM is configured with a host only adapter as well.
    So they are on the same network.
    This is confirmed once I ping them or open the FOG GUI in edge.

    However I’m still getting the following error on windows 10 after attemting a reboot over the network (PXE)

    During the FOG installation I pointed it to the correct IP for the second adapter and pointed it to the second adapter afterwards (as it requested if I wanted a different one) by default it seemed to have picked up the nat adapter.
    Given the error I expect there’s still a misconfiguration somewhere…

    At what location can I edit the ip settings for the fog server?
    I assume there is a way to do this directly via the consle.

  • @Sebastian-Roth
    thanks, seem to be getting closer to the root cause.

    Getting a PXE E53 error

    As per wiki:
    The DHCP request from the PXE client to timeout.
    •PXE-E53: No boot filename received. The client received at least one valid DHCP/BOOTP offer, but does not have a boot filename to download. There are several possible causes:
    •The DHCP Server and the PXE Server were located on the same server, but one of them was moved to a different server. This would result in an incorrect PXE Server configuration.

    Guess something must have gone wrong during the installation of the fog server that caused a misconfiguration in the network settings.

    To be continued, doing a fresh re-install

  • Senior Developer

    @red_john Is your windows 10 VM set to PXE boot?