• HI all sorry for the repeat of topic ( i suspect this has been answered for others OS’s ) but I haven’t seemed to be able to a solution that worked for fedora 21.

    When upgrading i seem to get stuck on the Stopping web service … failed and also fails setting up apache and php

    • When I manually install all the bits are there already , Apache, php, Mysql and all up to date.
    • I have stopped, started, enable, disabled and restarted php, apache etc and run the installer again.

    Not sure where to go from here.

  • Moderator

    @andy-king said in Fedora 21 version 1.2 to 1.5.4 version update fails:

    I would like to oput the large image files on an iscsi device do you think that is possible?

    Sure, mount that iSCSI device on your FOG server, move the existing directory structure in /images to the mounted iSCSI device (unmount the old disk/partition in case it was seperate), remount the iSCSI under /images and off you go without much headache.

  • @Sebastian-Roth

    Sorry Sebastian bin involved in something else - i’ve have more than one fog image i can boot back up without a loss so no real hard done. Will start to build the centos image on a vm and see how well it performs. I would like to oput the large image files on an iscsi device do you think that is possible?

  • Moderator

    @andy-king Maybe I can help you fix this up in a teamviewer session just so you are up and running again and don’t need to build up a new one under pressure? Around 4 PM UTC/CUT?! Just contact me via chat here in the forums.

    Give CentOS 7 a try I would say: https://wiki.fogproject.org/wiki/index.php?title=CentOS_7

  • @Sebastian-Roth

    THanks for your help, but no joy.
    Looks like i’m building a new version !
    Any recommendations for OS or comprehensive guides ?

  • Moderator

    @andy-king Not sure what to propose here. I do understand that you are looking for a quick win. It’s up to you but I don’t think keeping up a dated OS is a good choice.

    I guess you are stuck with a halfway updated FOG installation now, right? I guess the easiest you can try is add the REMI repo by hand. Create a new file called /etc/yum.repos.d/remi.repo and paste the following text into it:

    name=Remi's RPM repository for Fedora $releasever - $basearch

    Then run yum update and if you don’t get any errors you can run the FOG 1.5.4 installer again. Keeping my fingers crossed.

    But I highly encourage you to setup a fresh sever soon!!

  • HI Sebastian thanks for the reply,

    Fog has been good as gold for a while - only issue we have is we are now seeing more pcs with m.2 ssd drives which fog 1.2.0 doesn’t seem to like (running kernal 4.1 i think) hence the need to upgrade. Was just looking for a quick win.

    Fedora 21 was used simply because it was the only os i managed to get fog working correctly on. But open to any recommendations for any linux flavour as long as there are some guides on how to build; i am a windows guy so linux is a 2nd language for me.

  • Moderator

    @andy-king Ahh, now I see. I somehow missed you are using Fedora 21 (!!!) which is out of support since years. Why do you still use it?

    Usually the FOG installer is doing all that for you but it fails for Fedora versions older than Fedora 25 as files have been moved on the Fedora servers. I guess you can still install REMI repo or even PHP 7.0 on Fedora 21 by hand (see here https://rpms.remirepo.net/archives/fedora/21/php70/x86_64/repoview/) but I am wondering why you wanna do that.

    I’d advise you to setup a new fresh install with the latest Fedora release and install FOG 1.5.4 there. We have a wiki article that should help you migrate all your images and settings from the old server to the new one. https://wiki.fogproject.org/wiki/index.php?title=Migrate_FOG

  • @Sebastian-Roth
    THanks for the quick response


    tried to install remi-release-21 with yum yum install remi-release-21
    just says no package available

  • Moderator

    @andy-king said in Fedora 21 version 1.2 to 1.5.4 version update fails:

    Fatal error: Call to undefined function _() in ...

    I am very certain that you are still running an older version of PHP. Please run rpm -qa | grep -e php -e remi-release and post output here.

    How did you try to install remi-release-21? I guess this is the key to your issue. Commands used? Error messages?

  • :Update sorry for the delay - had a nose through the log file myself to see if anything there were some missing packages which i have managed to install manually (the php ones mainly) . though it still cant seem to install remi-relase-21 nor can it find it ? install completes ok but now getting

    "Warning: main(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone. in /var/www/html/fog/commons/text.php on line 22

    Fatal error: Call to undefined function _() in /var/www/html/fog/commons/text.php on line 22"

    when i look on line 22 its doesnt seem to have a reference to any timezone it’s a something to do with translation ?

  • Moderator

    @andy-king Please check out the error_logs in the install (bin) directory. Post part’s of the logs that might give us a hint on what’s wrong.