Deployment stops/waits very long with: Reattempting to update database ....



  • @george1421

    yes I can do that - but there is no /root/fogproject
    shall I create it?


  • Moderator

    @kratkale Are you willing to try 1.5.5 beta? You may be running into the issue that was already addressed in the working branch.

    If so from the linux console change to the git repository you downloaded using the git clone command.

    cd /root/fogproject
    git pull
    git checkout working
    git pull
    cd bin
    

    Then rerun the installer

    ./installfog.sh
    

    To switch back to the main repository you need to do the following.

    cd /root/fogproject
    git pull
    git checkout main
    git pull
    cd bin
    

    Then rerun the installer

    ./installfog.sh
    


  • @george1421

    No - it is not working …

    There is only one file:
    root@FOG:/home/kratkale# find /etc -name www.conf
    /etc/php/7.0/fpm/pool.d/www.conf
    root@FOG:/home/kratkale#


  • Moderator

    @kratkale phpf-pm is something new in FOG 1.5.2 and later. The developers have found some fine tuning settings once 1.5.4 was release (with 1.5.5 being delayed because of the summer holidays) we have to manually patch. I would expect that 1.5.5 to be released with all of the hot fixes soon ™.

    One thing you need to be sure is that you only have one www.conf file. We’ve see users having multiple version of php on their computer (I saw one user that have all 3 copies of php7 running at the same time. This caused a mess).

    So is your system working now (the 256MB ram should really help things).



  • @george1421
    No Problem - thank you for your help. On Monday school starts again and last week I got 87 new Computers.

    I will make some comments - maybe it helps someone …

    Well I use Debian net install 9.5 (installed 20180826)

    vi /etc/php/7.0/fpm/pool.d/www.conf
    php_admin_value[memory_limit] = 256M
    This entry is commeted out and with a value of 32M
    pm.max_requests = 2000
    This entry is in the Debian Version like you suggest
    pm.max_childrend = 35
    Here the Debian value is 5
    pm.min_spare_servers = 5
    Here the Debian value is 1
    pm.start_servers = 5
    Here the Debian value is2

    I can already confirm that the 4.15.2 Kernel is better. With the kernel after the FOG installation it took several minutes to delete the MPR Partition.

    Thank you so much for you help. Funny I use the FOG Server since many years - everything worked all the time out of the box.

    Now I cannot open the FOG Webinterface:

    Service Unavailable

    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
    Apache/2.4.25 (Debian) Server at 192.168.0.196 Port 80

    mhm


  • Moderator

    @kratkale Sorry I did not fully read the body of you OP. The subject line and body have two different fixes.

    Installing the 4.15.2 is the right answer for the delay in creation of the disk image.

    The multicast issue related to something else. Lets start with my standard response.

    ///
    Lets assume is the issue we’ve found after FOG 1.5.4 has been released.

    1. Change to the /etc directory from the fog server linux command prompt.
    2. Search for www.conf file. It can be in a number of locations depending on what version of php is installed. Use this command.
      find /etc -name www.conf (hopefully you will only find one)
    3. Edit that file file and ensure these settings are accurate. Don’t just add them since all should be there except php_admin_value[memory_limit] = 256M you will need to add that entry.
    php_admin_value[memory_limit] = 256M
    pm.max_requests = 2000
    pm.max_children = 35
    pm.min_spare_servers = 5
    pm.start_servers = 5
    
    1. Save and exit your text editor.
    2. Reboot the fog server.
    3. See if that fixes what is wrong. You really should only see this strangeness under heavy load, but I guess it might show up sooner under certain conditions.

    Also we found there is something strange going on in the linux kernels after 4.15.2, I’m going to recommend that you downgrade your FOG/FOS kernel to 4.15.2. The issue with later kernels is that its taking 3-5 minutes to create the disk structure under certain circumstances, where with 4.15.2 and older its only seconds to create the structure.

    Now the kernel will not impact your issue, but processing is incomplete might be related to the missing php-fpm configuration setting.
    ///

    Update the www.conf file and reboot the server. If that still doen’t fix the issue, the developers working on the multicast code in the 1.5.5 beta code. But lets see if we can fix it before going down that path.



  • @george1421
    It did not solve the problem;
    still waiting

    1. updating Database …
    2. Reattemting to update database …

    3. what to do?


  • @kratkale

    found it …
    just click on "DefaultMember FOG Version: (1.5.4)
    0_1535740727746_Bildschirmfoto_2018-08-31_20-37-45.png



  • @george1421
    can I see which kernel is used at the moment?


  • Moderator

    Please install FOS kernel 4.15.2 for both x64 and x32 bit systems. That will address the log delay in partition creation.


Log in to reply
 

377
Online

6.1k
Users

13.4k
Topics

126.4k
Posts