Can't capture an image



  • I have a default image that I use for a majority of my computers, and everything has worked great in the past. I have deployed the image, updated it as needed, and captured an updated copy multiple times. For some reason this is no longer working.

    I just updated one of our Windows 10 images to 1803, added an application, and updated all the runtimes. Afterwards I shut the computer down, then set up FOG to capture the image.

    The computer will boot, act as if it is sending the images to FOG, however it never finishes. I can watch the status in FOG on the Task Management, and it progresses as it should. After some time the computer finishes, and reboots. I’m able to log into the computer with no issues, and everything looks fine. After checking FOG, the Task Management shows the image sitting at 79% and does not move any more. I have left it for an hour or so just to be sure and there is no change.

    I have tried multiple times now with different images, and I get the same indication on all of them. I’m currently using FOG version 1.5.4 and we are trying to image our Lenovo m900 Tiny computers running Windows 10 x64.


  • Moderator

    @Towndrunk Please look at the chat bubble for additional information.



  • I thought I found my mistake, but it didn’t help. While updating the www.conf file, I made a change to one of the values, but didn’t remove the ; at the beginning

    ;php_admin_value[memory_limit] = 256M
    
    is now 
    
    php_admin_value[memory_limit] = 256M
    

    Here is a list of all the settings I have enabled in the www.conf file I have.

    [www]
    user = www-data
    group = www-data
    listen = 127.0.0.1:9000
    listen.owner = www-data
    listen.group = www-data
    pm = dynamic
    pm.max_children = 35
    pm.start_servers = 5
    pm.min_spare_servers = 5
    pm.max_spare_servers = 3
    pm.max_requests = 2000
    php_admin_value[memory_limit] = 256M
    


  • sudo systemctl start php7.1-fpm.service
    Job for php7.1-fpm.service failed because the control process exited with error code. See "systemctl status php7.1-fpm.service" and "journalctl -xe" for details.
    

  • Moderator

    @Towndrunk said in Can't capture an image:

    /etc/php/7.1/fpm/pool.d/www.conf

    This is the right one to edit. The other entries are saying you don’t have rights to view.

    The systemctl name is not right because each version of php has its own service name, my mistake.

    maybe you can try sudo systemctl start php7.1-fpm.service
    The service name is also a bit distro specific.



  • I ended up updating the /etc/php/7.1/fpm/pool.d/www.conf file. The values below are what I currently have.

    php_admin_value[memory_limit] = 256M
    pm.max_requests = 2000
    pm.max_children = 35
    pm.min_spare_servers = 5
    pm.start_servers = 5
    


  • sudo systemctl restart php-fpm
    Failed to restart php-fpm.service: Unit php-fpm.service not found.
    

    When I went in to edit the www.conf file and searched for it there was a single result the first time. I opened it and made the changes you requested, and the
    php_admin_value[memory_limit] = 256M was already in there. The value was 32M, but it was there.

    Now when I do the same search, there are multiple responses.

    find /etc -name www.conf
    find: ‘/etc/cups/ssl’: Permission denied
    find: ‘/etc/ssl/private’: Permission denied
    find: ‘/etc/vmware-tools/GuestProxyData/trusted’: Permission denied
    find: ‘/etc/polkit-1/localauthority’: Permission denied
    /etc/php/7.1/fpm/pool.d/www.conf
    

  • Moderator

    @Towndrunk You should have only needed to add the line for the memory limit.

    You may be able to see what is wrong by issuing this command form the fog server linux command prompt

    sudo systemctl restart php-fpm

    Then review the php-fpm log file in /var/log directory. There should be an error thrown why its not running. If you added any other lines but the memory one then I would start with confirming you didn’t add double entries.



  • I made these changes, and performed a reboot. . . and now FOG will not start. I ran through the install again thinking it may correct the service, but that didn’t help either. When trying to go to the FOG address in a web browser, I’m just getting Service Unavailable.

    When I did the search for the www.conf file, there was only one. So I’m sure that I was editing the correct file. I just wish I would have written down the original values now.


  • Moderator

    I’m going to start with my standard answer when 1.5.4 acts a bit fishy. Have you done the steps in the post below yet to tweak 1.5.4 into behaving:

    ////
    Lets assume is the issue we’ve found after FOG 1.5.4 has been released.

    1. Change to the /etc directory from the fog server linux command prompt.
    2. Search for www.conf file. It can be in a number of locations depending on what version of php is installed. Use this command.
      find /etc -name www.conf (hopefully you will only find one)
    3. Edit that file file and ensure these settings are accurate. Don’t just add them since all should be there except php_admin_value[memory_limit] = 256M you will need to add that entry.
    php_admin_value[memory_limit] = 256M
    pm.max_requests = 2000
    pm.max_children = 35
    pm.min_spare_servers = 5
    pm.start_servers = 5
    
    1. Save and exit your text editor.
    2. Reboot the fog server.
    3. See if that fixes what is wrong. You really should only see this strangeness under heavy load, but I guess it might show up sooner under certain conditions.

    Also we found there is something strange going on in the linux kernels after 4.15.2, I’m going to recommend that you downgrade your FOG/FOS kernel to 4.15.2. The issue with later kernels is that its taking 3-5 minutes to create the disk structure under certain circumstances, where with 4.15.2 and older its only seconds to create the structure.

    Now the kernel will not impact your issue, but processing is incomplete might be related to the missing php-fpm configuration setting.
    ////


Log in to reply
 

325
Online

6.1k
Users

13.4k
Topics

126.4k
Posts