Snapin install fails because system scheduled to rename host reboot



  • Re: Fog Client - Snapins run after computer rename/domain join

    FOG service= 0.11.0
    SVN Revision: 5712

    I am having the same issue as thread above - where the snapin works fine if I run the snapin on an already deployed image. However when the snapin runs and tries to install a program automatically after a deploy task the hostnamechanger creates a reboot task and then the snapin client tries to run but then instantly fails the install stating ‘User ERROR: A system shutdown is in progress.’

    Any help please?

    ---------------------------------SnapinClient---------------------------------

    22/08/2018 18:57 Client-Info Client Version: 0.11.0
    22/08/2018 18:57 Client-Info Client OS: Windows
    22/08/2018 18:57 Client-Info Server Version:
    22/08/2018 18:57 Middleware::Response Success
    22/08/2018 18:57 SnapinClient Snapin Found:
    22/08/2018 18:57 SnapinClient ID: 7
    22/08/2018 18:57 SnapinClient Name: Sophos Install
    22/08/2018 18:57 SnapinClient Created: 2018-08-22 16:45:58
    22/08/2018 18:57 SnapinClient Action: reboot
    22/08/2018 18:57 SnapinClient Hide: False
    22/08/2018 18:57 SnapinClient TimeOut: 0
    22/08/2018 18:57 SnapinClient RunWith: cmd.exe
    22/08/2018 18:57 SnapinClient RunWithArgs: /c
    22/08/2018 18:57 SnapinClient File: SophosSetup_NE.exe
    22/08/2018 18:57 SnapinClient Args: --quiet
    22/08/2018 18:57 Middleware::Communication Download: http://(FOG-server-here)/fog/service/snapins.file.php?mac=(MAC-here)&taskid=7
    22/08/2018 18:57 SnapinClient C:\Program Files (x86)\FOG\tmp\SophosSetup_NE.exe
    22/08/2018 18:57 Bus {
    “self”: true,
    “channel”: “Notification”,
    “data”: “{\r\n “title”: “Installing Sophos Install”,\r\n “message”: “Please do not shutdown until this is completed”\r\n}”
    }
    22/08/2018 18:57 Bus Emmiting message on channel: Notification
    22/08/2018 18:57 SnapinClient Starting snapin…
    22/08/2018 18:57 SnapinClient Snapin finished
    22/08/2018 18:57 SnapinClient Return Code: 1
    22/08/2018 18:57 Bus {
    “self”: true,
    “channel”: “Notification”,
    “data”: “{\r\n “title”: “Sophos Install Installed”,\r\n “message”: “Installation has finished and is now ready for use”\r\n}”
    }
    22/08/2018 18:57 Bus Emmiting message on channel: Notification
    22/08/2018 18:57 Middleware::Communication URL: http://(fog-server-here)/fog/service/snapins.checkin.php?taskid=7&exitcode=1&mac=(MAC-here)|&newService&json
    22/08/2018 18:57 User ERROR: Unable to get logged in users
    22/08/2018 18:57 User ERROR: A system shutdown is in progress. (Exception from HRESULT: 0x8007045B)
    22/08/2018 18:57 Power Creating shutdown request
    22/08/2018 18:57 Power Parameters: /r /c “Snapin requested restart” /t 0



  • @Sebastian-Roth sorry forgot to say when i run the snappin manually the sophos installer does not restart itself



  • @Sebastian-Roth I dont think so as I can run the snappin successfully after the image is deployed manually. But for automatic snappin run right after deploy it tries to run but the hostname changer starts its reboot and the snappin install fails. Then the snappin will not run again


  • Developer

    @kickers56 Maybe the Sophos installer is doing a forced reboot while finishing. Possibly that’s just to quick for our fog-client. Maybe installer parameters can fix that?


  • Moderator

    Mod note: Thread moved to fog problems.



  • Just realized this is in the wrong thread, as I created this post by linking from another post in Feature request. I can’t move it where it needs to be or delete it. Can someone please help move this?
    Thank you


Log in to reply
 

366
Online

5.8k
Users

13.1k
Topics

123.1k
Posts