installfog does not see php55-php-fpm



  • I am installing fog on RedHat 7 I edited the fogsettings file to reflect the internal repos we have and the installfog runs well until

    • Backing up user reports…Done
    • Stopping web service…Failed!

    Error log says :
    Aug 22 09:30:32 pl02149v mysqld_safe[41845]: 180822 09:30:32 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
    Aug 22 09:30:34 pl02149v systemd[1]: Started MariaDB database server.
    Failed to stop php-fpm.service: Unit php-fpm.service not loaded.

    the service for php-fpm is :

    systemctl status php55-php-fpm
    ● php55-php-fpm.service - The PHP FastCGI Process Manager

    I set php version in settings file :

    backupPath=’/home/’
    php_ver=‘5.5’
    php_verAdds=’-5.5’

    Still the error ?



  • I managed to make a simple symlink on the /usr/lib/systemd/system/ folder
    php-fpm.service -> /usr/lib/systemd/system/rh-php56-php-fpm.service and this seemed to clear the problem.

    thank you



  • @Quazz I am trying to see how to keep the name. The yum install takes the name like php55-php-fpm. I do not know how to alias it for the service name


  • Moderator

    Fog expects the service to still be called php-fpm, regardless of version number.


Log in to reply
 

479
Online

6.2k
Users

13.6k
Topics

128.0k
Posts