SOLVED host not registering

  • I PXE booted Lenovo T420 laptop and got to the FOG menu and selected Full host registration then laptop seems to loose connectivity and trying to contact DHCP again.

    Full host registration not going thru. don’t know why it’s trying to contact DHCP server again ?

    Here is screenshot.0_1534542039482_1.jpg

  • Dumb switch solved the issue. Please resolved this thread.

    Thank you for your assistance.

  • Moderator

    @mpatel said in host not registering:

    we have default spanning tree enabled on switches. can’t mess with that sorry

    This is going to be a problem. FOS boots so fast that by the time standard spanning tree starts to forward traffic FOS has already given up by 15 seconds ago. Standard spanning tree isn’t an issue for most operating systems since they typically take longer than 27 seconds to boot.

    If you can not enable fast spanning tree protocols then you either need to place an unmanged switch between the computer you want to image and the building network, or look at a different imaging tool. If FOG won’t work for you, then clonezilla is another linux based imaging tool that uses local usb storage for image capture and deploy.

  • we have default spanning tree enabled on switches. can’t mess with that sorry.

    i tried debug deploy option but can’t seems to figure out how exactly to do it.

  • Moderator

    If we assume it isn’t spanning tree, then what kind of network adapter are you using in this T420?

    If you go into fog and schedule a debug deploy to this target computer (hint: tick the debug checkbox before you schedule the deploy). If the host has not registered yet, you may have to manually register this target computer. PXE boot the target computer and it will start to deploy right away, but in debug mode, after several key presses you will be dropped to a linux command prompt. At the linux command prompt, key in ip addr show and look to see if

    1. network device eth0 exists
    2. if eth0 has an IP address.

    If both are true then we need to see if the target computer can ping your fog server listed in the screen shot.

  • Moderator

    @mpatel The issue is not specifically related to FOG.

    What happens is the network link is dropped momentarily as each boot kernel (operating system) is loaded. The typical spots where the net link is dropped is

    PXE Boot ROM -> iPXE
    iPXE -> FOS (fog customized linux program).

    With standard spanning tree, it doesn’t start forwarding packets until after listing for a BPDU packet for 27 seconds, if it doesn’t hear one then it starts forwarding data. This is called pessimistic blocking (assume there is a loop back while checking). With one of the fast spanning tree protocols spanning tree starts forwarding data right away while listening for a BPDU packet. This is called opportunistic blocking (assume there is no loop back while checking).

    Again the easy check is to insert a dumb switch (one that does not support spanning tree) between the target computer and building switch. If your problem goes away then you need to enable one of the fast spanning tree protocols. If the problem is still there then we need to look elsewhere.

  • This isn’t spanning tree related. if it was why would it get an IP at the beginning. computer is getting DHCP address then it loads the fog menu. then I do not see any reason for it to forget an ip and try re contacting DHCP.

    Fog suppose to work like this ? anybody seen this issue before ?

  • Moderator

    Will you place an unmanaged switch between the target computer and the building switch? Your issue could be spanning tree is enabled, but you are not using one of the fast spanning tree protocols (i.e. RSTP, MSTP, fast-STP, etc).

    If that doesn’t work then schedule a debug deploy (tick the debug check box before you submit the deploy task). PXE boot the target computer. After a few enter key presses it will drop you to a linux command prompt on the target computer. Run the following commands.
    ip addr show
    Ensure eth0 has an IP address. Then attempt to ping your fog server.