• We recently got a new shipment of HP EliteDesk 800 G4 desktops, but imaging is not working. Before we had 800 G2’s, and they still work fine (I just successfully deployed an image to an 800 G2 to make sure it wasn’t the FOG server).

    I am confused because on network boot, it grabs the right IP and even enters the FOG pxe interface, but if I do anything (deploy image, perform host registration) it goes to a black screen, displays about 20 ACPI Errors/Exceptions, initializes the random number generator, and says “Failed to get an IP via DHCP! Tried on interfaces(s):
    Please check your network setup and try again!”

    Then after a while it says “Press Enter to continue:” After pressing enter it displays this and restarts:
    Error Message

    It shouldn’t be having DHCP issues, because before it even boots into FOG it displays the MAC address of the computer and displays the correct IP.

    Any ideas as to what the issue might be? Are there certain NICs that just aren’t compatible with FOG?

  • Moderator

    @mecsr Great. I’m glad you have it working.

    Just as a word of warning, don’t advanced past the 4.15.2 version of the kernel until you update FOG, and even then stick with 4.15.2 until the developers can dig into why 4.17.0 is acting slow.

  • The bzImage kernel updates did the trick! Thank you so much for your help!

  • Moderator

    You should just be able to choose a version on the FOG Kernel Update page. Those images (on the wiki) are from 1.2 or 1.3 I think.

  • Moderator

    @mecsr OK grab the kernels from here


    They go in /var/www/html/fog/service/ipxe The 64 bit version needs to be saved as bzImage and the 32 bit version bzImage32.

    You can use the file command to read the version of the file for example file bzImage should report the version of the FOS kernel.


  • Okay, so we’ve actually ran into an issue with the updates.

    When going to Kernel Update in the FOG web interface settings, I am getting an FTP error:
    “Type: 2, File: /var/www/html/fog/lib/fog/fogftp.class.php, Line: 707, Message: ftp_put(): Could not create file., Host: XX.XX.XX.XX, Username: XX”

    We tried to get around this by manually FTP-ing into fog and copying the file ourselves, which we were able to do with no problems but we still get the error. We tried all of the steps on this page, but nothing works.

    The other option is to manually upgrade, as described here, but that will automatically upgrade to the latest version, which I believe is 4.17.0. Is there a way to manually upgrade the kernel to a specific version?

  • Is there a reason why I should only upgrade to 4.15.2? Can I update to the latest kernel?

  • Moderator

    @mecsr Interesting, linux kernel 4.11.0 should support the l219-LM network adapter. Upgrade to FOG/FOS kernel 4.15.2 (no higher for now) and then boot into the fog ipxe menu and check the hardware support.

  • Your explanation makes sense, thank you for your response!

    1. I am running 1.4.4 (which I now see is not the most recent)
    2. The kernel version (bzImage version) is 4.11.0
    3. The network device is an Intel 1219-LM

    Thanks for your help!

  • This post is deleted!
  • Moderator

    This is going to be a bit tricky to explain.

    FOG uses a third party component for pxe booting, its called iPXE. Its kind of like its own operating system. This iPXE manages the FOG iPXE menu. If you see the FOG iPXE menu then iPXE is getting an IP address. Once you pick a menu item, most will transfer bzImage and init.xz, this is FOS. Its a customized high performance linux operating system. THIS is what is not picking up the dhcp address (where iPXE did before).

    So now some questions for you.

    1. What version of FOG are you using?
    2. What version of FOG Kernel are you using? (can be viewed in the fog settings menu). If you haven’t updated it, then the version of FOG will tell us what we need to know.
    3. From a windows computer, go into the device manager, and the network adapter and get the hardware ID of that network interface. That will help us understand what nic is in that new computer model.
      Lastly its not so much FOG not supporting the network adapter, but its the Linux OS maybe not supporting the network adapter, and that’s pretty rare unless its a very new design.