Failed to open stream: Permission denied in /var/www/html/fog/status/logtoview.php



  • Hi all,

    In my clients recently, the FOG log has been reporting the following error:

    08/08/2018 15:56 Client-Info Client Version: 0.11.16
    08/08/2018 15:56 Client-Info Client OS: Windows
    08/08/2018 15:56 Client-Info Server Version: 1.5.2
    08/08/2018 15:56 Middleware::Response ERROR: Unable to get subsection
    08/08/2018 15:56 Middleware::Response ERROR: Object reference not set to an instance of an object.
    08/08/2018 15:56 Service Sleeping for 110 seconds

    I’ve checked the Apache log, and I can see the following error:
    [Wed Aug 08 15:14:08.956419 2018] [proxy_fcgi:error] [pid 39315] [client 10.1.1.107:58244] AH01071: Got error ‘PHP message: PHP Warning: fopen(/var/log/apache2/error.log): failed to open stream: Permission denied in /var/www/html/fog/status/logtoview.php on line 86\n’

    Running the following check seems to come back OK (ls -la /var/www/html/fog/status/😞
    total 60
    drwxrwxrwx 2 www-data www-data 4096 May 17 07:33 .
    drwxrwxrwx 10 www-data www-data 4096 May 17 09:42 …
    -rwxrwxrwx 1 www-data www-data 3304 May 17 07:33 bandwidth.php
    -rwxrwxrwx 1 www-data www-data 884 May 17 07:33 dbrunning.php
    -rwxrwxrwx 1 www-data www-data 1184 May 17 07:33 freespace.php
    -rwxrwxrwx 1 www-data www-data 1437 May 17 07:33 getfiles.php
    -rwxrwxrwx 1 www-data www-data 772 May 17 07:33 gethash.php
    -rwxrwxrwx 1 www-data www-data 661 May 17 07:33 getservertime.php
    -rwxrwxrwx 1 www-data www-data 813 May 17 07:33 hw.php
    -rwxrwxrwx 1 www-data www-data 587 May 17 07:33 index.php
    -rwxrwxrwx 1 www-data www-data 1515 May 17 07:33 kernelvers.php
    -rwxrwxrwx 1 www-data www-data 4416 May 17 07:33 logtoview.php
    -rwxrwxrwx 1 www-data www-data 830 May 17 07:33 mainversion.php
    -rwxrwxrwx 1 www-data www-data 721 May 17 07:33 newtoken.php

    I’ve restarted Apache, etc. but still this error persists in the log. It’s annoying as I can’t deploy any snapins to my client machines at the moment, which, as you all know, is pretty useful.
    Any help with this would of course be greatly appreciated as always!

    FOG INFO:
    You are currently running version: 1.5.2

    Latest stable version is 1.5.4

    Latest svn version is 6078

    Latest git version is 1.5.4



  • This can be marked as solved. I updated to 1.5.4 and everything is confirmed to be working once more. Thanks!


  • Senior Developer

    @RobTitian16 Check permissions on your log file: ls -al /var/log/apache2/error.log


Log in to reply
 

354
Online

7.4k
Users

14.5k
Topics

136.8k
Posts