Dell Precision Tower 5820 - FlexBay MiniSAS PCIe NVMe SSD not recognized



  • We actually use Legacy mode. We have found it to be much easier to manage, especially with our dual-boot images (W10 + Fedora 27).

    Switching to “AHCI” is one of our first changes before attempting to push an image. We also enable Legacy option ROMs and set the boot sequence to Legacy.

    We are able to image the Hynix drives in the new 5820 systems after removing the M.2 from the 5820 FlexBay port and installing it in a 5810 PCIe adapter. This makes us think the hickup is related to the pxe/tftpboot/bzImage process detecting the drive due to some difference introduced by the MiniSAS/backplane.

    Our typical BIOS changes:
    Enable Legacy Option ROMs
    Set boot option to Legacy
    SATA Operation = AHCI
    Disable Intel VMD Technology
    TPM off
    Secure Boot Disabled


  • Moderator

    @hlalex ok next question, since you are using a dell, and can we assume that you are pxe booting into uefi mode? If so, go back into the firmware and change the disk mode from “Raid-on” to “AHCI” mode. Then pxe boot your computer. There is a documented issue with LINUX and the intel rapidstore hardware when raid-on is enabled. After imaging but before the first OS boot you can switch it back with no harm. Or just leave it in ahci mode and have no harm.



  • Hey george,

    We do not have raid on the FOG server storage, and as far as I can tell the 5820s do not either. I have tried [CTRL] + I during boot and nothing comes up. Also, in BIOS the only raid options I see pertain to SATA drives (also disabled), while the NVMe drive shows up under “PCIE Drives” > “MiniSAS PCIe SSD-0”.

    Let me know what data you need and I will get it up.


  • Moderator

    Do you have your storage setup as a raid?

    If not we may need to do some data collection steps to find out a bit more about that hardware.


Log in to reply
 

289
Online

7.5k
Users

14.6k
Topics

137.6k
Posts