Force install mysqldb instead of mariadb



  • I am trying to install FOG on a RedHat 7.5 virtual server. The repos for most packages are local(in house but up to date) . mysqldb is the preferred db but the fog install script keeps trying to install maraidb. Is there a parameter that can be passed to foginstall.sh to do mysqldb insted of mariadb ? I tried to change the packages in fogproject-1.5.4/lib/redhat/config.sh to mysql mysql-server but it had no effect



  • @leonj So try to go to the web interface, and then immediately check the apache error log file. Post the last 20ish lines of that, sanitized if necessary. Also - we need to know what versions of MySQL and PHP and php-mysqlnd you are using.



  • @wayne-workman Thanks for the reply. I am now using the .fogsettings file. My only problem is we have specific versions of different packages on local repo that needs to be used. eg mysql 5.7 and there is also some php elements eg. php-mysqlnd that is version 71 . So I get the install to complete upd to the point of pausing for you to go to the webinterface and activate/update the database. But then I get the feeling that fog is not communicating with mysql ( mysql is running and http is running) From the browser I can get up to the default apache page.



  • I updated the article. Be sure to look at the packages section, as it’ll have the ones you need for RHEL mostly.



  • @leonj Pre-create the /opt/fog/.fogsettings file and specify the packages you want in it. Then run the installer and it will honor the settings. More information on the file can be found here: https://wiki.fogproject.org/wiki/index.php?title=.fogsettings

    That article only has a Debian config file… I’m going to update it with the packages for CentOS 7 since that OS is widely used for FOG.


 

438
Online

5.4k
Users

12.6k
Topics

118.9k
Posts