• Hi,
    We recently changed over to a new DHCP server last week and now when we reboot machine it is using our Fog server for IPv4 DHCP server. It is also using our old DNS server info. So new DCHP is not taking new settings but is taking our fog server IP address. If I turn off fog server everything works fine but it is when fog server is on that causes this. So new DCHP server has new IP address and is also doing DNS. Settings for bootfiles 66 and 67 are same in the new server. I took a screen shot because I reran installer thinking it might need to be run. I did find an interesting line in the setup and wondering if this is causing it. It says using Fog DHCP as YES. DHCP router address is still the same as we have used in past. Any advice or suggestions would help. Seems to be FOG server causing issues but guessing it is just a setting. If I can have any info on how to change settings that would be great also. Thanks

  • @bmick10 said in DHCP Server Change:

    I think I have tried to get in by clicking on and said I didn’t have access even though I am administrator.

    Linux doesn’t have the concept of ‘Administrator’, that’s a Windows thing. Linux has users, and root. And sometimes users are allowed sudo privileges for some or all commands. Really, you need to be root to edit the file. Usually, that’s done via CLI.

  • @wayne-workman Just a quick question. Not a Ubuntu expert. Going to try this tomorrow but when I go to /opt/fog/.fogsettings can I get in there edit directly or will/can I do from command line. I think I have tried to get in by clicking on and said I didn’t have access even though I am administrator. Just wanted to know best option to get into .fogsettings
    I also found this in forums. Just want to see if this maybe option. You can use “dpkg --get-selections | grep dhcp” to get the exact package name. I believe it’s “dhcp3-server”, so “sudo apt-get remove dhcp3-server” should get it.

    Thanks for help!

  • @bmick10 Just set dodhcp to N inside of your /opt/fog/.fogsettings file and re-run the installer.
    More information: https://wiki.fogproject.org/wiki/index.php?title=.fogsettings#dodhcp
    After you re-run the installer, you should try to turn off the DHCP service with systemctl stop dhcpd;systemctl disable dhcpd

  • 0_1532299936567_Fog Settings.jpg