• I have FOG 1.5.2 on an UBUNTU server. When I try to register a client, however, I get:
    Initializing random number generator.
    Starting etho0 interface and waiting.
    UDHCPC: started, v1.27.2
    UDHCPC: sending discover
    UDHCPC: sending discover
    UDHCPC: sending discover
    UDHCPC: no lease, failing

    I tried researching on my own. I read somewhere that the original kernel 1.2.0 didn’t have this problem, but the newer ones do for some reason. How do I deal with this? My skills are very limited so I need a “solution for dummies”.

  • @tom-elliott Wow, you’re awesome! We’re actually getting a new network because of E-Rate within the next month. I am logging your explanation/suggestions and will run this by the guys installing the switches. Thanks.

  • Senior Developer

    @tony-fiorentino Yes, but another reason this may be failing is potentially 2 main things.

    1. STP (Spanning Tree Protocol) is enabled on your network, but it is not enabled in the “Fast/Rapid” methodology. The dumbswitch makes the port maintain an “up” status and the switch then handles passing the traffic to your DHCP server. See if your network guys can enable fast/rapid stp?

    2. 802.3az (Power Saving) Switches. Your switches ports are literally turning themselves off as they think the network is not in use after iPXE hands off to the Linux Kernel. (Using a dumb switch keeps the port open and the switch handles directing the traffic through your network.)

  • Yep, the “dumb mini-switch” eliminated the problem. So, if I carried around a small switch and plugged the network drop into it instead of directly into the clients, and then connected the clients to the dumb switch, that would work? I’d rather a permanent solution if possible.

  • Senior Developer

    @Tony-Fiorentino Please connect a dumb mini switch between client and your main switch. See if the problem goes away. If it does we can start digging into switch settings like spanning tree, energy saving and such.