Deploy associed image on boot menu



  • Hello,

    On boot menu, actually, users can deploy every images on a host .
    I work in a IT school, so student may reset host after test, like a sandbox.
    Could it be possible to limit deploy the associated image to the host ?
    Or/and could it be possible to limit a user to access to only one image ?

    Lebrun



  • We have made a special setting in deploy.image menu for the computers of the room. Then login and password are not requested to access to deploy menu.

    #login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param hostname ${hostname}
    goto host_${hostname} || goto autres
    :host_bug
    :host_win10-3
    :host_i207m01
    :host_i207m02
    :host_i207m03
    :host_i207m04
    :host_i207m05
    :host_i207m06
    :host_i207m07
    :host_i207m08
    :host_i207m09
    :host_i207m10
    set username userlogin
    set password userpassword
    params
    param username userlogin
    param password userpassword
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    goto fin
    :autres
    login
    params
    param username ${username}
    param password ${password}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fin
    

  • Moderator

    @lebrun78 it is possible to have only the assigned image in the deployment list via the menu. Can’t recall what setting it is right now.
    EDIT: as George said item in FOG Settings under FOG Boot Settings will allow you to display the images as a list or not.

    Also how are your students able to access it, a username and password is needed to access the menu


  • Moderator

    I know there was a discussion a while back about this specific issue. I “thought” the developers added that feature request at that time. This allowed only the defined image to be deployed to the computer from the Deploy image menu.

    I’m not in the office at the moment, but look in the FOG Settings->FOG Configuration page. Under the boot menu settings there should be a check box about image list or deploy menu (something). Uncheck that and see what happens.


 

532
Online

5.4k
Users

12.6k
Topics

118.7k
Posts