Type: 8, File: /var/www/html/fog/lib/fog/fogcontroller.class.php, Line: 1046, Message: Undefined offset: 3



  • I ran into this error when I was trying to submit in a snapin on our FOG server.

    I saw the suggestion for fix here:

    https://forums.fogproject.org/topic/11202/fogcontroller-class-php-undefined-offset-3-line-1046

    However, I tried that and still getting the error message.

    Wondering if there is anything else I can look at?


  • Moderator

    @skasai In addition/instead of using iptables once could restrict nfs access on the nfs share level too. I understand you have a working build so don’t change just because of this, but be aware that with NFS v3 you can restrict mounting the NFS share based on ip address/subnet range.



  • I believe I found the cause of the issue.

    We are running CentOS 6 with FOG version 1.4.3

    I was forced to restrict the iptables to not advertise NFS to the rest of our campus and only to our subnets.

    In that process, I did not allow for iptables to allow lo (loopback, 127.0.0.1) to be accepted, which will also cause this error.

    While I did allow for 127.0.0.1 being the source, which fixed nfs having issues with RPCBind, it does not solve the trying to submit a snapin to FOG as it appears to use -i lo interface path.

    This issue should be considered resolved.


 

512
Online

41.6k
Users

12.1k
Topics

114.3k
Posts